Lightroom Classic: import slow

  • 2
  • Problem
  • Updated 7 months ago
  • (Edited)
I upgraded to LR Classic as soon as it came out. I haven't reported this because it seemed so obvious that I was sure Adobe would jump to fix it right away, but I guess not, so here I am to report it.

Every time I import images into my catalog it takes about 15 to 20 MINUTES to perform the import.  This is egregiously slow and extremely aggravating.  Especially since, before the LR Classic release, imports of 400-500 images would take mere "seconds". 


My workflow:

1) I copy all images to my m.2 SSD drive (m.2 drives are a lot faster than SSD drives that you plug into regular hard drive slots)


2) I import into LR with preview set to MINIMAL (I don't want LR spending any time on generating previews yet)

3) After the import, I sort by capture time (images are coming in from multiple cameras) and rename the images.

4) Finally I do a standard preview generation.



Steps 1, 3 and 4 are all about the same speed as they have ever been.  Only the import is affected.  And the progress bar sits there looking like it is doing absolutely nothing for most of the 15-20 minutes.  I'm at the point where I come home, do step 1, start step 2 and go to dinner. 

Also, it doesn't really matter much whether I am importing a portrait session with maybe a couple hundred images or a wedding with a couple thousand, the overall import time is about the same - because most of that time is spent sitting there appearing to do nothing (and because it's only minimal previews, none of the time is spent generating previews).


Importing minimal previews was super fast before upgrading to LR Classic. Can somebody please look into this and get it fixed?
Photo of David Terry

David Terry

  • 2 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 2
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 25 Posts
  • 7 Reply Likes
Hi David,

We are looking into the issue. Could you please provide some more info on the catalog i.e catalog size and no. of images in the catalog?


Thanks
Mayuri
Photo of Steve Lipofsky

Steve Lipofsky

  • 7 Posts
  • 0 Reply Likes
Mayuri.

You will see a thread regarding VERY slow import of new images with 7.0.1. from many users.

My cat has more than 1,500,000 images but I had no problem with import speed prior to this release.

I see that you were looking into this a week ago. Please update me asw to what you know so far.

Thanks, Steve
(Edited)
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 25 Posts
  • 7 Reply Likes
Hi Steve,

We are able to replicate the issue on large catalogs. We are working on the fix.

Thanks,
Mayuri
Photo of Steve Lipofsky

Steve Lipofsky

  • 7 Posts
  • 0 Reply Likes
I've had some success in rebooting my computers (Windows 10).  I'll see if that is a reliable work around. 

The import function definitely behaves differently with this update.

The import bar and the generate preview bar now appear at the same time in the upper left and hang there for a while befores and images appear.
Photo of Steve Lipofsky

Steve Lipofsky

  • 7 Posts
  • 0 Reply Likes
Just tried a photo merge and Lightroom hung with almost no CPU activity. I rebooted and it worked just fine.