Lightroom Classic: import from SD Card no refresh

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
If I import from a SD card, then eject it. Add photos to the card, then put the card back in the Win 10 PC and try to import the next set of photos they do not show. There is no way to refresh the card contents, other than restarting Lightroom Classic CC. Odd... can anyone help.
Photo of Frogger

Frogger

  • 8 Posts
  • 2 Reply Likes

Posted 2 months ago

  • 1
Photo of Tom Mickow

Tom Mickow

  • 284 Posts
  • 95 Reply Likes
Known bug.  Try navigating to the SD card using the Files section instead of the Devices section of the Import dialog and I think you'll be ok.
Photo of Frogger

Frogger

  • 8 Posts
  • 2 Reply Likes

Thanks.. that works, Incidentally I have just discovered that "Show Import when memory card is detected" doesn't work either. Perhaps the issue is related.


Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 319 Posts
  • 110 Reply Likes
Thanks for reporting the first issue.
A fix is on the way.
The "Show Import Dialog When Memory Card is Detected" should work though.
Does this problem persist? 

Thanks,
Sunil
Photo of Frogger

Frogger

  • 8 Posts
  • 2 Reply Likes

Yes the problem persists... I have rest option restarted and done other things. my PC is 64bit

OS Name:                   Microsoft Windows 10 Home
OS Version:                1803 10.0.17134 N/A Build 17134

Lightroom Classic CC 7.3.1

If Lightroom is closed and I insert a SD Card, Windows Explorer opens and display the files on the card. If Lightroom is Open and I insert the card NOTHING happens, not even Windows Explorer.



Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3550 Posts
  • 643 Reply Likes
Lightroom Classic CC Version 7.4 was released earlier today and should have a fix for this issue. Give it a try and let us know if you continue to see this problem. Thank you for your patience!