LIGHTROOM - Import from camera now very s-l-o-w

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
The problem is the incredibly slow import from camera since I changed from Lightroom 6 to Lightroom CC - a move I'm much regretting because of that! I have disabled the new screen, but it is still very slow. Anything I can do about it?
Photo of Nigel Dutt

Nigel Dutt

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Which OS version are you using?
Did you install the LR 6.3 / 2015.3 update?
Photo of Nigel Dutt

Nigel Dutt

  • 4 Posts
  • 0 Reply Likes
I'm using OS X el Capitan. Not on 2015.3, so will install that and report back...

Thanks
Photo of Nigel Dutt

Nigel Dutt

  • 4 Posts
  • 0 Reply Likes
Just tried with 2015.3 but still very slow - using the same camera connected to the same port as I've always used with LR. I can see that there is a lot of connection activity with the camera, but nothing visible happening. The thumbnails are also very slow to show compared to how it used to work on LR 6 before I switched to CC. I'd say that what used to take seconds is taking many minutes.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
MacOS 10.11 does have some known issues with USB, cameras, and even importing camera files from cards. Apple is working on the problems, and everyone else is scrambling to find ways to work around them.
Photo of Nigel Dutt

Nigel Dutt

  • 4 Posts
  • 0 Reply Likes
Just tried the same upload from Mac to Photos and that works fast, at the same speed that LR 6 used to. The only thing that changed in my environment between fast uploading and slow uploading was the switch from 6 to CC.

I also tried copying all the photos on my camera to my Mac using "image capture", which was fast and then importing the same photos from the Mac to LR CC and that was fast too, so this would be a workaround if camera-->LR is slow.