Lightroom: Deleting rejected photos while in Develop doesn't work

  • 32
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Since the last LR update, images have been "stuck" in the Develop module. It happens regularly, but so far I've been unable to identify a triggering event. For example, I was editing an image in Develop this morning. Then went to the Library module and selected a different image. When I clicked back to Develop, the original image I'd been working on was still displayed. Clicking any other module displayed the new image I wanted to work on, but the Develop module continued to display the original image. (Note: I don't necessarily have to select an image in Library to make this happen - sometimes just selecting a new image while still in Develop will yield a stuck image.) If I try to make edits to the image, it is the new image that gets the changes, not the stuck image, so it's only an issue with the previewed image. 

The only current fix for this is to close and reopen LR. When I do, the image that I wanted to work on is now displayed.

I understand from Victoria Brampton that you may already be working on this. And I note there is a thread of others complaining of the same issue: https://forums.adobe.com/message/9201341#9201341 

If I can help you with information about my settings, please let me know what you need. FYI, I'm on Windows 10 (all updates are current) and Adobe CC (all updates are current).
Photo of SJ Disenhof

SJ Disenhof

  • 6 Posts
  • 1 Reply Like
  • frustrated

Posted 3 years ago

  • 32
Photo of Jeff

Jeff

  • 74 Posts
  • 20 Reply Likes
I'm also having this problem. I hadn't associated it with image deletion but that's certainly possible and I'll keep watch for that. Windows 10 build 14986 (Insider Slow), latest LR CC.
Photo of Paul Plak

Paul Plak

  • 138 Posts
  • 19 Reply Likes
Me too. I just deleted a photo (remove from disk) i, the develop mode, and the last preview will stick on the develop screen, only exiting LR and reopening will fix it. Win10 LR CC.
(Edited)
Photo of Eddie Miller

Eddie Miller

  • 1 Post
  • 0 Reply Likes
I have the same problems. Remove from disk and hung picture in develop mode.
Photo of Jeff

Jeff

  • 74 Posts
  • 20 Reply Likes
I had this happen today and I did not remove any images first. The only thing I did differently was clicked on the auto collection for the latest import (one picture).
Photo of Angus McIntyre

Angus McIntyre

  • 2 Posts
  • 0 Reply Likes
I've not seen these exact symptoms -- stuck in Develop mode -- but I've also had problems when deleting rejected photos while in Develop mode. On my system, rather than being 'stuck' in Develop mode, Lightroom switches to Library, but reports an error. See https://forums.adobe.com/message/9280731

It sounds as if the same underlying problem may trigger slightly different behaviors, perhaps varying depending on the platform.

Mine is MacOS X 10.12.2, Lightroom 2015.8 (build 1099473). 
Photo of Nathan Rodriguez

Nathan Rodriguez

  • 1 Post
  • 0 Reply Likes
I am having this exact problem and it's rather frustrating! I have deadlines to meet and this is throwing a major stick in the mud for that. Please fix quickly!!
Photo of helevitia

helevitia

  • 1 Post
  • 0 Reply Likes
Add me to the list.  I can reproduce this 100% of the time.  If I select multiple photos, then right-click, select "remove photos", the last photo shown in developer mode gets stuck.  Only closing and re-opening Lightroom will make the problem go away.
(Edited)
Photo of Marcel Van der Horst

Marcel Van der Horst

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Image Selection Locked in Lightroom CC.

In the latest CC release of LR, the image remains locked in the developed module and you cannot select another. You can in the selector but the main image window remains locked to the last image worked on. Have to shut down and restart.
Photo of Jo Lyons

Jo Lyons

  • 1 Post
  • 0 Reply Likes
I have the same issue, however it happens after I delete a rejected photo.  I use LRCC 2015.8 on a Mac OSX  10.11.6 
Photo of Diane Seddon

Diane Seddon

  • 1 Post
  • 0 Reply Likes
Happening to me all the time now - driving me nuts - LR freezes, tells me it is unable to change modules, and will not let me change the preview image.  Usually after I've edited, and marked for deletion in the Develop module. 

I run a MAC with 32Gb RAM,  PS/LR CC and Sierra.  This seems to be happening from the time of the update.
Photo of lesfstl

lesfstl

  • 4 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled lightroom cc 2015.8 module bug.

Every time I delete rejected photos and then try to switch back to my library or develop module I get an error and I have to shut down Lightroom CC and sometimes I have to force quit.  Really disappointed in the last few updates from Adobe.  They have been riddled with bugs.  What gives?  Almost thinking the creative cloud cost is not worth the issues I keep encountering every time Adobe releases and update.

Running Mac also
(Edited)
Photo of Scott Southerland

Scott Southerland

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Deleting rejected photos.

I'm experiencing this same issue in Lightroom CC 2015.8

Note: This conversation was created from a reply on: LIGHTROOOM: Issue with "Delete Rejected photos" function.
Photo of Russ Khabal

Russ Khabal

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled LIGHTROOOM: Issue with "Delete Rejected photos" function.

Frequently, after utilizing the "Delete Rejected photos" function and choosing "Delete from disk" option, the Develop module begins to malfunction – photos selected in the filmstrip do not have a preview in the main window or the navigator; selecting the Library module and then going back to Develop module produces an error, "An error occurred when attempting to change modules." A restart of Lightroom usually resolves the issue.

Lightroom 5.3 / OS X 10.9.1 / Mac Pro Mid-2010 / 12GB RAM
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6933 Posts
  • 1565 Reply Likes
Adobe released Lightroom 6.9/CC2015.9 today.

This issue should be corrected in this release. Please give it a try and let us know if you see any further issues. 

Complete information about this update can be found at the Lightroom Journal: http://blogs.adobe.com/lightroomjournal/2017/03/lightroom-cc-2015-9-now-available.html

If you don’t see the update in your Creative Cloud App, you can use the kbsc [Cmd/Ctrl]+[Opt/Alt]+[ R ]  to refresh your app. If you are a perpetual license holder, you can access the update via Help>Updates...

Refer to this for any installation issues: http://blogs.adobe.com/lightroomjournal/2013/06/keeping-lightroom-up-to-date.html#lrcc2015
(Edited)
Photo of mikmar110

mikmar110

  • 9 Posts
  • 0 Reply Likes
It is not corrected.  When I delete photos in any mode LR locks up and I have to quit and reopen.  Using Apple Sierra 10.12.3 (16D32) .
Photo of Carlos Cardona

Carlos Cardona

  • 668 Posts
  • 131 Reply Likes
I'm not having that problem, with an iMac Retina, the same OS. Have you tried marking them as rejected, and then invoking Delete Rejected Photos? As a workaround?
Photo of mikmar110

mikmar110

  • 9 Posts
  • 0 Reply Likes
No, I have not but I will.  I simply select the photos I want to delete and then do remove from disk and LR seizes up.  thank you.
Photo of mikmar110

mikmar110

  • 9 Posts
  • 0 Reply Likes
I tried it that way and it seems to work, thanks.
Photo of Robert Howen

Robert Howen

  • 1 Post
  • 0 Reply Likes
Sorry Rikk, this problems is NOT SOLVED.  Still crashes.  Not happy with LR.
Photo of Jo-ee Bolton

Jo-ee Bolton

  • 3 Posts
  • 2 Reply Likes
If you have the latest release of LR CC, it has been fixed.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16608 Posts
  • 2701 Reply Likes
Photo of Tom Holub

Tom Holub

  • 1 Post
  • 1 Reply Like
The problem is still present in Lightroom Classic CC 7.0.1 on High Sierra 10.13.1. 
Photo of Angus McIntyre

Angus McIntyre

  • 2 Posts
  • 0 Reply Likes
Yes. This problem was fixed in some earlier versions of Lightroom, but appears to have resurfaced in Lightroom Classic. I just reproduced it in Lightroom Classic CC 7.0.1 on MacOS X 10.12.6 (Sierra).

Adobe's support team on Twitter have denied that the problem exists, but I can reproduce it reliably on my system.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16608 Posts
  • 2701 Reply Likes
Creating a new topic. I can reproduce and will follow up with Eng team

Please reference the new conversation here: Lightroom Classic 7.0.1: Error switching modules after deleting rejected photos i...