Lightroom: Deleting rejected photos while in Develop doesn't work

  • 32
  • Problem
  • Updated 9 months ago
  • Solved
  • (Edited)
Since the last LR update, images have been "stuck" in the Develop module. It happens regularly, but so far I've been unable to identify a triggering event. For example, I was editing an image in Develop this morning. Then went to the Library module and selected a different image. When I clicked back to Develop, the original image I'd been working on was still displayed. Clicking any other module displayed the new image I wanted to work on, but the Develop module continued to display the original image. (Note: I don't necessarily have to select an image in Library to make this happen - sometimes just selecting a new image while still in Develop will yield a stuck image.) If I try to make edits to the image, it is the new image that gets the changes, not the stuck image, so it's only an issue with the previewed image. 

The only current fix for this is to close and reopen LR. When I do, the image that I wanted to work on is now displayed.

I understand from Victoria Brampton that you may already be working on this. And I note there is a thread of others complaining of the same issue: https://forums.adobe.com/message/9201341#9201341 

If I can help you with information about my settings, please let me know what you need. FYI, I'm on Windows 10 (all updates are current) and Adobe CC (all updates are current).
Photo of SJ Disenhof

SJ Disenhof

  • 6 Posts
  • 1 Reply Like
  • frustrated

Posted 2 years ago

  • 32
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 3554 Posts
  • 645 Reply Likes
Official Response
With Aundray's instuctions, I was finally able to duplicate the bug. It has been filed.