Photoshop: iMac 4k (late 2015) screen flickering issue

  • 7
  • Problem
  • Updated 10 months ago
  • (Edited)
I am a retoucher so i use Adobe Photoshop to do my work.
Recently i've bought a new iMac 21.5 (late 2015) with cool 4k Retina display.

OS X El Capitan 
Version: 10.11.3 (15D21)
iMac (Retina 4K, 21.5-inch, Late 2015)
Processor: 3,1 GHz Intel Core i5
Memory: 8 GB 1867 MHz DDR3
Graphics: Intel Iris Pro Graphics 6200 1536 MB

But the happiness was gone very quickly after installing Adobe Photoshop and tries to do my job. The matter is that i've found a disgusting bug. My screen goes black/begins flickering/flashing (video is here -

First my think was - perhaps this is a problem with key combinations or graphic tablet. So i switched off the tablet and checked hotkey settings and tried once more - the problem didn't gone.

Next i tried to repeat the bug. I've realized that there is no any sequence of actions. Screen flickers randomly. But i noticed - pressing CMD,SPACE,[] keys makes screen to flick more often (when using brush or stamp tools).

So the next step was Google. I found lot of such issues:

I have already tried:
1) different combinations of advanced graphic processor settings - nothing changed
2) turning off use of GPU - nothing changed
3) update my OSX to the latest version - nothing changed
4) update Adobe Photoshop to the latest version - nothing changed
5) restore PS settings to default - nothing changed

There is ONLY ONE REALLY WORKING solution -
+Chris Hong Here's a very lousy solution - I realised that this issue is happening only when my cursor size for eraser is too big. I just went to the Preferences>Cursor and made the cursor to precise. It stopped the blinking issue. Although it makes the work little difficult on photoshop.
This is really worked but made PS is usless for me (and as i've understood for many users of new iMac 4K too).

I tried to make a return of iMac but my Apple retailer told me that this is software problem. So they cannot take my iMac back and make me a refund.

Dear Adobe and/or Apple,
Please solve this terrible issue.
I look forward to your reply and the resolution of my problem.

Thank you.
Yours faithfully,

p.s. sorry for my English.
Photo of alyona


  • 19 Posts
  • 1 Reply Like

Posted 3 years ago

  • 7
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15078 Posts
  • 2144 Reply Likes
Official Response
We are working with our partners to resolve this issue.

The workaround is to use Precise cursor (either by setting them to precise in the Preferences > Cursors dialog or by hitting the Caps Lock to temporarily set the precise cursor).