Lightroom Classic: ICC Profile Changes when changing module

  • 1
  • Problem
  • Updated 6 months ago
  • (Edited)
If soft-proofing is not turned off before exiting the Develop Module, when opening a consecutive  image, Lightroom will automatically apply whatever profile was last used for soft-proofing to the current image even if the current image had a previously-applied, different profile. Furthermore, the image copy name will be immediately and automatically overwritten with the current profile name, and the current profile will be immediately and automatically applied to the image.  




For example, let's say I have two images, Image 1 and Image 2.  Image 1 was previously soft-proofed in sRGB, and Image 2 was previously soft-proofed with MyPrinter.icc (I'm using a fictitious profile as an example; it can be any ICC profile).  Now let's say I do some work on Image 2, but before I go back to the Library module, I forget to turn off soft-proofing.  I go back to the LIbrary module, select Image 1.  As soon as Image 1 is opened, the color profile switches to MyPrinter.icc, and the copy name Becomes "Image 1 MyPrinter.icc".  



I can manually switch the profile back to the correct one (in this case sRGB), but I'd have to really be paying attention to remember which profile I was using.  I'll also have to manually change the copy name.  This is a huge pain when we're talking about trying to remember lots and lots of profiles across multiple virtual copies of the same image (like one would have if they're printing the same image on two different printers with 3 different paper types apiece).  Add to this batch editing with auto-sync changes, and there's potential to really screw up a lot of files in one click (ask me how I know!).  The changes are not reflected in the image history, either.



My work-around, essentially is: don't do any soft-proofing or printing in/from Lightroom.  Don't ever turn it on.  Do all my soft proofing in Photoshop, save the image there, and simply use Lightroom for DAM.  
Photo of Patrick Regan

Patrick Regan

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 1131 Posts
  • 366 Reply Likes
I can't confirm what you are seeing using LR 7.3.1 on Windows 7.

1) Check Soft Proofing in the Develop module.
2) Select file IMG_0001.CR2, click on 'Create Proof Copy,' and select Profile sRGB.
3) Select file IMG_0002.CR2, click on 'Create Proof Copy,' and select Profile Legion Photo Gloss 4000.
4) Switch back to the Library module, select file IMG_0001.CR2.
5) With file IMG_0001.CR2 selected switch back to the Develop module.
6) Selected soft proof profile and copy name do NOT change.

I tried this a number of different ways with no change to the originally selected soft proof profile or copy name.

Try resetting your LR Preferences file, which may be corrupted and causing this issue.

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

You can simply move the Lightroom Preferences.agprefs file to your desktop, which will allow restoring it if the issue persists. Make sure to close and restart LR, which will create the new Preferences file.
(Edited)
Photo of Philippe Coudé du Foresto

Philippe Coudé du Foresto

  • 44 Posts
  • 15 Reply Likes
I couldn't reproduce it either (LR 7.3.1, Windows 7). I second the suggestion to reset your LR preferences.