I still need Lightroom 4 because I have a MacBook Pro version 10.6.8

  • 1
  • Question
  • Updated 5 years ago
I have a MacBook Pro version 10.6.8. I want to get Photoshop Lightroom but cannot download Lightroom 5 and cannot figure out where to get Lightroom 4. Please help.
Photo of Jessica Torch

Jessica Torch

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 1

Be the first to post a reply!