Elements: I loved 3.0, hate 10.0

  • 1
  • Question
  • Updated 6 years ago
  • (Edited)
Dear Adobe, PLEASE change Photoshop Elements to how it was before! I used Adobe Image Ready, then Photoshop Elements 3.0, now I purchased the new Photoshop Elements 10.0 along with my new Macbook. Well, while some new features are needed upgrades I guess, I absolutely hate the design.

I HATE to see the black/dark grey background. The older versions where had white background. And I absolutely HATE the way the Photoshop Elements !0.0 forces the user to have that big black screen filling my mac screen, in order to have access to the tools bars. I LOVED how in version 3.0, the Photoshop had white-background bars framing my screen, allowing me to use multiple windows inside.
Now, the photoshop ugly dark grey fils my screen, and I have to move it to have access to Safari, file folders, etc. That means, I spend way too much time moving Photoshop, the photo frames around.

The other thing I HATE about version 10.0 is that when I want a photo to "fit on screen," the version 10.0 chooses the (small) screen of the dark grey window, the one I place lower on my screen so as to be able to see my Safari window as well. In the old version 3.0, fit on screen meant that the photo would fill my *computer* screen -- and I like it that way.

Anyhow, I do not like those "improvements" in version 10. Please do not toss out good old features in favor of design-of-the-day. Now I HAVE TO look, everyday, to the dark grey Adobe screen I absolutely hate. I still love working with the old Adobe Photoshop Elements on my old iMac desktop.

Is there any way to change the background color of Elements 10? Is there any way to go back to Elements framing my desktop screen while leaving the middle "free" to float all windows, including Safari and file folders etc?
Photo of Irrinel Petrescu

Irrinel Petrescu

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 17 Reply Likes
To get back your screen in pse 10 go to Window and turn off the Application Frame.

In the the photoshop elements>preferences>general check Allow Floating Documents in Full Edit Mode.