I have Lightroom 4 on Windows Vista 64-bit; can I upgrade to LR5 with this system?

  • 1
  • Question
  • Updated 5 years ago
Lightroom 4 works perfectly with Windows Vista 64-bit, both of which are up-to-date with all updates. I don't want to have to install a new operating system - I have no other need for it.
Photo of Paul Murphy

Paul Murphy

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of James Hess

James Hess

  • 166 Posts
  • 23 Reply Likes
Although the Lightroom 5 beta worked on Vista, the final release version requires at least Windows 7.