Photoshop: I can't run any scripts

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
When I go to run a script in Photoshop, it says it can't find the Javascript plugin. When I look in my plugin folder it is empty.
Photo of Neal Miller

Neal Miller

  • 5 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
In Photoshop CS6 and CC, the plugins folder is for third party plugins only.
The Photoshop supplied plugins are in the Required folder (visible on Windows, inside the package on MacOS).

But it sounds like you are missing the required plugins as well.
Did you accidentally move the application away from it's support files and folders?
Photo of Neal Miller

Neal Miller

  • 5 Posts
  • 0 Reply Likes
I haven't moved anything. This is on a PC running Windows 8. I just looked and there are a bunch of things in the required folder under plugins but I don't see anything that appears to be the Javascript plugin. What am I looking for?

Thanks,

Neal
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
ScriptingSupport.8li
Photo of Neal Miller

Neal Miller

  • 5 Posts
  • 0 Reply Likes
I just did a search and it is here...

C:\Program Files (x86)\Adobe\Adobe Photoshop CC\Required\Plug-Ins\Extensions

Is that where it is supposed to be?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
yep, that is the location for the 32 bit version of Photoshop.
The 64 bit version is in a different location (according to Microsoft's wishes).
Photo of Neal Miller

Neal Miller

  • 5 Posts
  • 0 Reply Likes
Well, my computer is a 64 bit machine...that could be the issue.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
It depends on which version you are running - both the 32 bit and 64 bit versions are installed (because some plugins and devices don't support 64 bit addressing yet).
Photo of Neal Miller

Neal Miller

  • 5 Posts
  • 0 Reply Likes
OK...well this is Photoshop CC (64-bit). Do I need to move anything? Or should this be working and there is another issue?