ELEMENTS 11: problems saving files on MacOS 10.9

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
Hello,

I have photoshop Elements 11 for Mac OSX Mavericks and everything was fine with it, then 2 days ago the it simply wouldn't let me save anything anymore, I press save as and use the keyboard shortcut but nothing happens, a small ghost image appears in bottom left corner but I cannot interact with it and I have no choice but to quit the application, it is essentially useless without being able to save... what should I do? I tried searching for a solution on the internet but couldn't find anything. help, please! I need photoshop!
Photo of wayne jinks

wayne jinks

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Did this only start after you installed MacOS 10.9? There are a lot of known issues in MacOS 10.9 affecting many applications, and the OS open and save dialogs are driven by the OS and not the application.
Photo of wayne jinks

wayne jinks

  • 2 Posts
  • 0 Reply Likes
Hi, thanks for the reply. No it only started about 2 days ago, its been working fine with OS 10.9 for months, not a single issue, and now its basically useless. I tried changing the view from cover flow to columns/list and icons but still nothing. it opens files fine and all the other dialogue boxes show up without any problems, its just the "save as" option thats messed up, it asks me to wait, but then nothing happens and then that image of the save box shows up in the corner but I can't do anything with it. I tried resetting the preferences in photoshop but that didn't work either... so I'm stumped :/
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
It appears that the OS is drawing parts of the save dialog in the wrong place. But it doesn't look like the normal "on the other screen you disconnected" problem that we commonly see (where the OS still says the second display is attached, even when it is not).

This could be related to some of the other known drawing bugs in MacOS 10.9 -- the white menus/dialogs issue in particular. We have a plugin that works around that OS bug (posted in the topic on white/blank menus: http://feedback.photoshop.com/photosh...), and it should also work in Elements. But this sort of sounds like it isn't quite the same thing. So try the plugin in Elements, but I'm not super confident that it will fix this issue.