Lightroom: Chokes on large keyword lists (Windows only)

  • 16
  • Problem
  • Updated 1 month ago
  • Acknowledged
  • (Edited)
Please see the image - I cannot scroll any further down the keyword list after the word 'coloured'. This is a much more recent problem than the separate keyword export issue I have just reported but it means that I cannot do even a manual fix of that other issue.Help much appreciated!Scott
Photo of Scott Hortop

Scott Hortop

  • 10 Posts
  • 1 Reply Like

Posted 7 years ago

  • 16
Photo of Anita Dennis

Anita Dennis

  • 75 Posts
  • 24 Reply Likes
If you're on a Mac, try Option-clicking the green dot in the upper left corner, the maximize window button. That should re-fit the window to your screen. I'm not sure if Alt-click does the same on Windows, though.
Photo of Scott Hortop

Scott Hortop

  • 10 Posts
  • 1 Reply Like
Hello Anita
On Windows I unfortunately see no green dot - I've tried a few other options but nothing seems to make any difference.
The other keyword issue I mentioned is now fixed but this problem is still in place so it means that they were not related.
Scott
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Hi Scott,

This is a bug on Windows. The keyword list stops functioning after about 1630 or so keywords. The bug has been logged.

The one workaround we've found is to make the keyword list hierarchical by nesting keyword families together. This will shorten the list and allow more keywords to be viewed and/or selected and used.

Becky
Photo of Roland Röder

Roland Röder

  • 3 Posts
  • 1 Reply Like
Lightroom LR3, LR4, LR4.1RC2: When working with a very long keyword list (~1500) and scolling down with the mouse wheel, the focus get lost after estimated ~1000 entries and the keywords below could not be selected. This error exists since several versions.
Workaround: using a keyword filter shortens the list and allows the selection.

This reply was created from a merged topic originally titled
Lightroom LR3, LR4, LR4.1RC2: long keyword list looses focus.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3905 Posts
  • 1037 Reply Likes
The same limitation occurs with the Keyword column in the Library Filter Metadata browser -- if more than a couple thousand keywords are showing (e.g. in Flat View), LR starts acting erratically.

Collapsing the hierarchy in the column isn't always a viable workaround. The only way in LR to reliably find photos explicitly assigned with a parent keyword is to use Flat View in the Keyword column.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3905 Posts
  • 1037 Reply Likes
See this post for a workaround:

http://forums.adobe.com/message/59626...
Photo of Paul Hetherington

Paul Hetherington

  • 24 Posts
  • 1 Reply Like
also experienced by me, and sometimes it even crashes LR & laptop
not good - very annoying indeed.
quite unbelievable that this has been hanging around unaddressed for so long
Photo of Marion Stelts

Marion Stelts

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled
Why has selecting a keyword with a mouse click in Lightroom5 suddenly stopped working?.


I have been working with Lightroom5.3. My list of keywords had gotten long so I experimented with adding hierarchy. I seemed to work as advertised with dragging other keywords under the parent keyword.

I left to do some other tasks. When I resumed I could no longer highlight (or select) a keyword in the list of all the keywords, let alone drag it.

I am using Windows 8.
Photo of Carlos Oliveras

Carlos Oliveras

  • 115 Posts
  • 27 Reply Likes
I recently started experiencing this problem. And this is happening in a program that is supposed to help in tagging photos? Still, seeing that this topic is 4 years old and the issue has not been fixed, does not surprise me. There are many relevant bugs that have been reported and acknowledged since 3-4 years ago, but they are never fixed.

I don't agree with LR team's priorities (or maybe it's marketing priorites) - I think bugs from 4 years ago should be fixed before adding new features like the ones in LR CC.
Photo of Sara Bequette

Sara Bequette

  • 8 Posts
  • 1 Reply Like
I'm having this same issue on Lightroom CC (2015) - the newest version. I can't believe they still haven't addressed this issue! >.< Wow... 
Photo of John R. Ellis

John R. Ellis, Champion

  • 3905 Posts
  • 1037 Reply Likes
I just tested this problem on Windows 10 with LR CC 2015.6, and the limit is now about 3270 keywords, just about twice the former limit of about 1630.  I wonder if Windows 10 has doubled the maximum size of the underlying Windows control (which was formerly limited to 2^15 ~~ 33,000 pixels).
Photo of Hans Wildschut

Hans Wildschut

  • 1 Post
  • 1 Reply Like
I have the same problem with showing lists of keywords. My catalogue contains about 280.000 pictures, all with several keywords and now it is very problematic that not all keywords are shown in selections that are rather big (several thousands of pictures). I realy hope Adobe will address this beacause otherwise LR becomes rather useless for me.....
 
Photo of Kevin Lozaw

Kevin Lozaw

  • 6 Posts
  • 1 Reply Like

Same Problem:

I was looking for a keyword I couldn't recall. When I checked the Keyword list in the right side panel I noticed that the list stops at the work Oak.

I tried the Library Filter and it displays a little further, up to the phrase "OK Corral".

I know there are many other keywords.

I have a total of 4,838 keywords according to the Library Filter

Total of 160,000 images in the catalog.

Windows 10 Desktop PC


Sure hope Adobe can fix this some day.

Photo of Harold P Anderson

Harold P Anderson

  • 12 Posts
  • 3 Reply Likes
How can Adobe not fix this? Limiting users in this way for so long is unconscionable.
Photo of Henrik Zawischa

Henrik Zawischa

  • 88 Posts
  • 7 Reply Likes
I had issues reorganizing my keyword list hierarchically as suggested, as LR (7.1 on Win 10) froze on every second move. Asking for help I was pointed to this thread. Seems pretty similar, possibly related.
As IT pro I got curious and dug into the SQLite DB (which is the catalog). I found some redundancy in the tables and something that worries me: the ids for all keywords along a path down hierarchy to any keyword are stored with this keyword as a string. This could be a potential issue with deeply nested hierarchies.
Currently I am at 2157 keywords on my list with 1841 being on the top-level. Bit by bit I manage to get more structure into it and bring LR back to life. Not really happy.
Henrik Zawischa
Photo of Stephen Barnes

Stephen Barnes

  • 5 Posts
  • 1 Reply Like
I have a very strongly structured keyword hierarchy of over 33,000 keywords (yes, I know!) and I'm getting the screen blanking issue when I enter a keyword starting with "S".

I haven't really had any other issues, but this screen blanking issue is a real pain in the backside.

Is there any plan to fix this issue?
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
Do you mean when you enter a keyword starting with "S" in the Keywording panel?
Photo of Kanheiya Agrawal

Kanheiya Agrawal, Employee

  • 41 Posts
  • 10 Reply Likes
Hi Stephan,

Please share your catalog with us. You can upload and share me the link. I will try to reproduce this issue. 
Your system info please.

-Kanheiya
Photo of Not Disclosed

Not Disclosed

  • 3 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Lightroom Classic blanks screen when keywords exceed 1020 starting with same lett....

I recently found that on entering the letter "s" in the Keyword Tags box, the screen would blank and then flash.  Pressing Esc or any other letter would bring it back.

Having carried out some tests, I have found that this behaviour occurs once there are more than about 1,020 keywords which start with the same letter.

Having counted initial letters of keywords in Excel, I found I had 1,088 beginning with "s".  As a test, I increased the number of keywords commencing with the next most frequent character, which happened to be "c".  As the number beginning with "c" approached 1,020, the drop down text of suggested keywords (typing "c" in the Keyword Tags box) began to blur, and once it reached 1,020 (approximately), the same screen blanking behaviour as I had on typing "s" occurred.  Removing a couple of the "c" keywords stopped the blanking behaviour, adding a couple to replace them started it again.

There seems to be a clear bug which, at least on my Windows 10 system with plenty of RAM, causes Lightroom to choke when searching its database if it contains more than about 1,020 keywords which begin with the same letter being searched.

Photo of John R. Ellis

John R. Ellis, Champion

  • 3865 Posts
  • 1019 Reply Likes
Windows LR has a long-standing bug that Adobe has decided not to fix -- it chokes when you get more than about 1500 keywords. The only workaround is to introduce hierarchy (or more hierarchy) into your keywords and keep most of the hierarchy collapsed in the Keyword List panel.
Photo of Not Disclosed

Not Disclosed

  • 3 Posts
  • 1 Reply Like
Thanks for the reply.

My keywords are already in a hierarchy, which goes some 6 or 7 levels deep in places, maybe even more in a few instances. It has a dozen or so top level category headings to which the list is collapsed most of the time because any other view would be hopelessly unwieldy. It sounds as if I have been lucky that it has worked for as long as it has, because I reckon I have about 3,300 keywords (plus synonyms which would approximately triple the count).

If Adobe is not going to address this issue, I guess it is going to have to be goodbye Lightroom. There is little point to having a database which is incapable of growing as your library of images expands. Maybe Adobe sees the cataloguing and keywording functions as being for amateurs or small-time users and accepts that those with larger portfolios will look elsewhere, but with the proliferation of digital photography I would imagine that more and more people are going to come up against these limits.

It is disappointing that long standing limitations in the keywording functions generally have not received attention for years. This seems to be another, of which I was not previously aware.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3865 Posts
  • 1019 Reply Likes
Note that the bug only strikes when you have more than about 1500 keywords currently displayed. So by keeping the hierarchy collapsed, you won't encounter the bug. Rather than explicitly expanding the hierarchy, you can use the Search box in the Keyword List panel to get to the keywords you're interested in.  And I quite agree -- painful and annoying.
Photo of dmeephd

dmeephd

  • 222 Posts
  • 50 Reply Likes
I, as well as others, can confirm that this issue does not occur under the Mac OS—in any version going back to 2014.

It's strictly a Bill Gates bug.
Photo of Martina Halberschwang

Martina Halberschwang

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Moving keywords in the keyword list.

LR CC 8.0
There is a problem moving keywords from one hierarchy level to another using the mouse (drag & drop).

Steps to reproduce (in my case):

- 2000 items in the root of the keyword list
- OK: Moving one item (e.g. number 385) under another item to generate a new hierarchy level.
- Not OK: Moving one item (e.g. number 1885) under another item to generate a new hierarchy level or just moving it to another level. LR works some time and then all items in the keyword list are marked up to the item number 1885.

This was tested on two different Windows 10 PCs, with a "work" catalog and with complete new catalog. On all test scenarios the tests were OK from item 1 to 1649. With number 1650 (exactly) and higher all tests went wrong.

Photo of John R. Ellis

John R. Ellis, Champion

  • 3905 Posts
  • 1037 Reply Likes
LR also chokes when there are more than about 1500 folders in the Folders panel or 1500 collections in the Collections panel. The original sin here was Adobe's.

Every
 Windows application with large scrolling lists  has to cope with the maximum size that Windows imposes on low-level windows (32K pixels) by repainting the windows as necessary. Most applications do that by using commonly available libraries of user-interface controls that do the work for them. 

But Adobe took a shortcut when they implemented LR Windows, choosing to implement their own controls but failing to complete the work. They did it for Library grid view but not Folders, Collections, Keyword List, and other panels. And they've never owned up to taking that shortcut.  See here for details: 
https://feedback.photoshop.com/photoshop_family/topics/bug-that-causes-collections-and-publish-servi...