I use PS CC. If I download PS CS3, to be able to use an older filter (Lucis Art), will it mess up PS CC? Can I have both without conflict?

  • 1
  • Question
  • Updated 4 years ago
Photo of Lois Stanfield

Lois Stanfield

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 767 Reply Likes
The plugin should install in the plugins folder of one version - and can't interfere with other versions of Photoshop.
Yes, you can have both versions of Photoshop installed without conflict. But CS3 is not guaranteed to run on current OS versions.
Photo of Lois Stanfield

Lois Stanfield

  • 2 Posts
  • 0 Reply Likes
Thank you, Chris! Yes, you have a point there. It may not work on newer OS. Oh well! Was worth a try.