I need to restore my Lightroom from a previous backup because I changed the name of the catalog file and all photos have ? marks

  • 1
  • Problem
  • Updated 10 months ago
How may I find the date on which I changed the catalog anme in order to restore?
Photo of popcolligan

popcolligan

  • 2 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 1
Photo of Todd Shaner

Todd Shaner, Champion

  • 991 Posts
  • 324 Reply Likes
Renaming a LR Catalog .lrcat file shouldn't cause the problem you describe (? marks on photos). However, you also need to rename the associated Previews and Smart Previews .lrdata folders as outlined here:

https://helpx.adobe.com/lightroom/kb/catalog-faq-lightroom.html#HowdoIrenameacatalog
(Edited)
Photo of popcolligan

popcolligan

  • 2 Posts
  • 0 Reply Likes
hmmm...looks like i neglected to rename the preview and smart preview folders as well.  Thanks for the great link!     Will read carefully and try to rename them with the same name.  Really hope it does the trick!
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1229 Posts
  • 495 Reply Likes
It won't. Not renaming the previews and smart previews means that Lightroom will have to rebuild those. It will rebuild the previews automatically, so you still should not see this problem. A question mark on the folders means that Lightroom can't find the photos however (and so it won't be able to rebuild the previews either). You must have changed folder names too, or perhaps your photos are on a disk that has a different drive letter than before (if you use Windows).