Elements 14: Slowest photo organizer ever. Can anyone explain what is going wrong?

  • 2
  • Problem
  • Updated 2 years ago
  • (Edited)
I have just upgraded from Elements 10 to Elements 14 and now have the slowest photo organizer ever, I am wishing I had never purchased 14. Can anyone explain what is going wrong?
Photo of David Lambert

David Lambert

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 2
Photo of Dale Moegling

Dale Moegling

  • 32 Posts
  • 7 Reply Likes
Not sure of your operating system .. if you are on Apple .. well, it's a known problem and there really is no fix.   Know they are working with Apple .... 
Photo of David Lambert

David Lambert

  • 2 Posts
  • 0 Reply Likes
Windows 7 Professional, service pack 1. processor i7. 8GB ram.
Photo of Rens Jansen

Rens Jansen

  • 40 Posts
  • 6 Reply Likes
this forum is full of complaints on Elements14, but Adobe seems silent/ not monitoring this forum...A's helpdesk has recently reacted to a complaint I posted on Twitter, suggesting I call to their US helpdesk? I'm not aware A works w Apple to solve....A. doesn't list this in their abundant commercials or system requirements.....I run on MBPro OSX El Capitan 10.11.6 (latest osx) BUT for now I have stopped using E 14! 
Photo of Ralph Atkins

Ralph Atkins

  • 3 Posts
  • 1 Reply Like
So silent because they don't want to hear all the problems we are having and they won't do anything to assist from what I see.  My old version for years 4, was the best.  It didn't try to control me and what I wanted to do.
Photo of JediSQL

JediSQL

  • 9 Posts
  • 0 Reply Likes
If I stick to the Media View (the original Organizer since it was Photoshop Album 2.0), I do not notice any problems.  With my Win10 on i7 computer, I see some minor slowness in the People View.  However, when I get into the Places view, it gets slower than molasses.  

I have over 9000 images, most of which I have in a mapped Places tag.  It seems that every time you visit or zoom the map, Organizer goes through all your Place tagged photos to see if they should be in one of the location pins on the portion of the map currently visible.  I timed it the other day.  I would let the pins all fill in.  Then I would click the + or – on the map to zoom it.  It would take about 2 minutes, 13 seconds for Organizer to re-display the location pins.  That SERIOUSLY cramps my workflow productivity.

See my "Exclude Photos from Location Mapping" post at:
https://getsatisfaction.com/photoshop_family/topics/exclude-photos-from-location-mapping
Photo of Ralph Atkins

Ralph Atkins

  • 3 Posts
  • 1 Reply Like
Elements 14 is for the birds.  The old version 4 was the best for me as I could do what I wanted not what some software designer thinks I should want.  Now half of what I have won't work in Elements 14 and it also locks me up in other things I do.  Waste of my money.
Photo of Rens Jansen

Rens Jansen

  • 40 Posts
  • 6 Reply Likes
Windows or OSX? I have same experience on Macbook Pro, latest s/w. I got Adobe helpdesk finally responding bbut sofar only "we will loop in experts". Very Bad! Lots of crashes!
(Edited)
Photo of Ralph Atkins

Ralph Atkins

  • 3 Posts
  • 1 Reply Like
I am windows 7.