Lightroom Classic: The picture panel goes black and the program crashes

  • 11
  • Problem
  • Updated 1 year ago
  • (Edited)
LR classic CC crashes
Photo of Adri


  • 2 Posts
  • 1 Reply Like

Posted 2 years ago

  • 11
Photo of Никита Чунтомов

Никита Чунтомов

  • 1 Post
  • 2 Reply Likes
Maybe i found a solution.
Go to

Open Camera Raw GPU Config

and change in  text file from opengl to directx. 
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1714 Posts
  • 593 Reply Likes
First follow the above FAQ and test out the latest GPU driver from AMD. 

If you want to fall back to DirectX, just delete the C:\Users\%Username%\AppData\Roaming\Adobe\CameraRaw\GPU\Camera Raw GPU Config.txt file.

To force OpenGL, after the config file gets regenerated after a relaunch and quit of Lr, edit the text file in a text editor, look for the "directx" and replace it with "opengl".
Photo of James Hildreth

James Hildreth

  • 18 Posts
  • 2 Reply Likes
Thank you for following up. I think your comment pertains to Photoshop and Camera Raw. I don’t have a problem with CR, only LR Classic CC. Furthermore I don’t care if it uses OpenGL or DirectX. I would just like the black screen in LR to go away while using whichever acceleration LR wants to use or I can force it to use. LR Classic CC has worked in the past with either (but not recently with OpenGL which is what it wants to use now). CR never had problem no matter which acceleration it wanted to use; it now wants to use OpenGL and it works.
Photo of Ben Smith

Ben Smith

  • 6 Posts
  • 0 Reply Likes
Thanks for replying back.

I have just turned my PC on to find that there is a new update for CC.  Upon opening and browsing to the Preferences, the program is now using DirectX.  I did not delete the txt file like you suggested, so I imagine the new build must have changed the accelleration back to DirectX.

DirectX : Radeon RX580 Series (25.20.14003.1010)

Problem solved. No more black screen!!!

Thanks for your help!
Photo of James Hildreth

James Hildreth

  • 18 Posts
  • 2 Reply Likes
I updated to LR8 but still wants to use OpenGL and still have black screen. But PS20 is using OpenGL fine.
Photo of Renato Richina

Renato Richina

  • 15 Posts
  • 2 Reply Likes
I have also the same issues still with LR8, Windows 1809, Nvidia GTX 1070 Ti 8GB. Mostly, it happens when exporting pictures (between 100 - 200 in a row). Sometimes, it can be "fixed" by reloading the Win Graphicsdriver by CTRL+ALT+WIN+B key combination. But after I have to restart the pc that LR is working stable again for a time. For sure, latest Nvidia graphcis driver installed.

I tried the "workaround" with removing "OpenGL" from the "Camera RAW GPU Config" file, but this did not resolve it. As James sayed, LR is the only program where it happens, also no problem with PS and any other (graphcis) program