Lightroom Classic: The picture panel goes black and the program crashes

  • 10
  • Problem
  • Updated 9 months ago
  • (Edited)
LR classic CC crashes
Photo of Adri

Adri

  • 2 Posts
  • 1 Reply Like

Posted 2 years ago

  • 10
Photo of Никита Чунтомов

Никита Чунтомов

  • 1 Post
  • 2 Reply Likes
Maybe i found a solution.
Go to
C:\Users\%Username%\AppData\Roaming\Adobe\CameraRaw\GPU

Open Camera Raw GPU Config

and change in  text file from opengl to directx. 
(Edited)
Photo of Arnold Bartel

Arnold Bartel

  • 196 Posts
  • 52 Reply Likes
Great observation!

This setting really changes the GPU mode.
By setting it to opengl on my Windows 10 system it makes the error reoccur.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
Follow https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html to try to update the GPU driver the latest version from the vendor. I recommend doing a clean driver install because we've found cases in the past that without the clean driver install, it does not always purge the old driver bits from the system. This is especially true for Windows.
(Edited)
Photo of Arnold Bartel

Arnold Bartel

  • 196 Posts
  • 52 Reply Likes
I have already done the clean driver install several times.
The final solution for this issue was forcing Lightroom/Camera Raw to use DirectX instead of OpenGL (see the observations in this thread).
This switching to DirectX was - at least at my system - only possible by updating to Windows 10.
Photo of Arnold Bartel

Arnold Bartel

  • 196 Posts
  • 52 Reply Likes
Simon:
I would appreciate if you could try to reproduce this issue with by switching to OpenGL (using the config.lua flag or Camera Raw GPU Config) and change folder in Develop mode).
Is there anybody who can confirm that there are systems using GPU enabling and OpenGL mode where this issue doesn't occur?

Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
Lr will go through the DirectX path on Windows by default. It would fallback to OpenGL if it detects runtime issues with it. After updating your Windows and the latest GPU driver, you could give DirectX another shot via the method documented above. Or I would simply delete the C:\Users\%Username%\AppData\Roaming\Adobe\CameraRaw\GPU\Camera Raw GPU Config.txt (Lr will recreate it).
Photo of Arnold Bartel

Arnold Bartel

  • 196 Posts
  • 52 Reply Likes
Simon, I appreciate your efforts very much. I for myself have already solved the problem on my system by using DirectX.
I just wanted to know if the issue is located in LR / Adobe SW or if it's an issue in the video driver. So it would be interesting to get information if it also occurs on other systems when OpenGL is activated instead of DirectX.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
We don't see widespread issues with this. We do test the OpenGL path internally. From what I saw on the reported occurrences on the forum, most if not all are machine/GPU card specific. That means the driver is most likely the culprit.
Photo of James Hildreth

James Hildreth

  • 5 Posts
  • 2 Reply Likes
I see this issue also but only in LR and NOT camera raw. In LR I have to use directX but in photoshop/camera raw I can use OpenGL. I have an older GPU but it was previously approved and worked correctly in earlier v7 versions of LR. It has always worked in camera raw. So I think there is some difference between camera raw and LR in handling the GPU. I have the latest non-beta drivers.
Photo of James Hildreth

James Hildreth

  • 5 Posts
  • 2 Reply Likes
After the latest LR Classic and PS update both are now back to using OpenGL instead of DirectX. Camera Raw works fine but now LR suffers from the black screen when I develop a second picture. No problem previously with DirectX. Was something changed in these latest updates?
(Edited)
Photo of Ben Smith

Ben Smith

  • 6 Posts
  • 0 Reply Likes
I also have the black screen effect, but in CC, rather than Classic CC.

When swaping from grid to loupe view in CC ( where the library and develop modules are effective combined ) the image goes black under GPU accelleration.  When disabled, the image reappears.  I am sure that this is caused by OpenGL ( either ATI or Lightroom code ).

As there is a way to edit the Camera Raw GPU Config.txt to force Lightroom to use OpenGL, then there must be a way to force it to use DirectX?  I have tried a few different versions with varying capitalization, but nothing works so far.

Anyone have any ideas?
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1573 Posts
  • 514 Reply Likes
First follow the above FAQ and test out the latest GPU driver from AMD. 

If you want to fall back to DirectX, just delete the C:\Users\%Username%\AppData\Roaming\Adobe\CameraRaw\GPU\Camera Raw GPU Config.txt file.

To force OpenGL, after the config file gets regenerated after a relaunch and quit of Lr, edit the text file in a text editor, look for the "directx" and replace it with "opengl".
Photo of James Hildreth

James Hildreth

  • 5 Posts
  • 2 Reply Likes
Thank you for following up. I think your comment pertains to Photoshop and Camera Raw. I don’t have a problem with CR, only LR Classic CC. Furthermore I don’t care if it uses OpenGL or DirectX. I would just like the black screen in LR to go away while using whichever acceleration LR wants to use or I can force it to use. LR Classic CC has worked in the past with either (but not recently with OpenGL which is what it wants to use now). CR never had problem no matter which acceleration it wanted to use; it now wants to use OpenGL and it works.
(Edited)
Photo of Ben Smith

Ben Smith

  • 6 Posts
  • 0 Reply Likes
Thanks for replying back.

I have just turned my PC on to find that there is a new update for CC.  Upon opening and browsing to the Preferences, the program is now using DirectX.  I did not delete the txt file like you suggested, so I imagine the new build must have changed the accelleration back to DirectX.

DirectX : Radeon RX580 Series (25.20.14003.1010)

Problem solved. No more black screen!!!

Thanks for your help!
Photo of James Hildreth

James Hildreth

  • 5 Posts
  • 2 Reply Likes
I updated to LR8 but still wants to use OpenGL and still have black screen. But PS20 is using OpenGL fine.
(Edited)
Photo of Renato Richina

Renato Richina

  • 15 Posts
  • 2 Reply Likes
I have also the same issues still with LR8, Windows 1809, Nvidia GTX 1070 Ti 8GB. Mostly, it happens when exporting pictures (between 100 - 200 in a row). Sometimes, it can be "fixed" by reloading the Win Graphicsdriver by CTRL+ALT+WIN+B key combination. But after I have to restart the pc that LR is working stable again for a time. For sure, latest Nvidia graphcis driver installed.

I tried the "workaround" with removing "OpenGL" from the "Camera RAW GPU Config" file, but this did not resolve it. As James sayed, LR is the only program where it happens, also no problem with PS and any other (graphcis) program