Photoshop: I can't use shortcut for font size decreasing on Czech keyboard with English UI.

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
If I have:
1) Czech keyboard
2) English UI
And I am using "Ctrl + Shift + ,"    
– English equivalent is (Ctrl + Shift + <)
Then is strikethrough applied

If I have:
1) Czech keyboard
2) Czech UI
And I am using "Ctrl + Shift + ,"    
Then is font size decreased

If I have
1) English keyboard
2) Czech UI
And I am using "Ctrl + Shift + ,"    
Then is font size decreased

Can I fix it somehow in: c:\Program Files\Adobe\Adobe Photoshop CC 2015.5\Locales\cs_CZ\Support Files\Shortcuts\Win\Default Keyboard Shortcuts.kys ?
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 809 Posts
  • 187 Reply Likes
  • that my workflow is broken

Posted 2 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 390 Reply Likes
Howdy Jaroslav,

So, I played with this a little, including checking the keyboards from other languages.  The quick answer is use the Czech programmer's keyboard.  The long answer is below...

If the English version of Photoshop is given the shortcut CTRL+SHIFT+< then the size of any selected or active text is increased.  It doesn't make a difference what keyboard layout you use.  I tried English, German, French, Argentine Spanish, Finnish, and Turkish.  I also tried the Czech Programmers keyboard and everything worked perfectly.  The default Czech keyboard, however, added a strike through.

Now, I think, at least speaking from the perspective of English, that this is all correct and As Designed.  Why?  Cuz the default Czech keyboard has ? and the SHIFTED version of , which is the keystrokes we're really entering.  And when I use a different keyboard, such as French or Turkish or Finnish and I enter CTRL+SHIFT+? (on a keyboard where ? is a shifted value) I get underline.

The default Czech keyboard doesn't have the < or > keys, so these commands are unavailable.

Hope that helps,
David
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 809 Posts
  • 187 Reply Likes
Thanks for reply. The point why I am talking about this is that I didn't found the way how to set shortcut for text size decreasing. Because you can't use scripts or actions in text-edit modal state. I want send screenshots in English and you don't want learn Czech :-D , but I use always Czech in my designs. This shortcut is hardwired in code same as shortcut for selecting next layer in layers panel and it is not accessible with certain settings.

Czech programmer's keyboard is same as english with small adjustments. Not good choice for me :-D 

btw What is the purpose Default Keyboard Shortcuts.kys in Locales folder? Content is a bit different between two languages. I guess this differences should make accessible basic shortcuts in certain language without changing settings. So I can use exactly same keys for show/hide grid regardless of the keyboard language (by default if UI lang is same as keyboard lang).