Photoshop: I can't open on my iMac running Catalina 10.15.3

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress
  • (Edited)
Yesterday I installed the most recent version of macOS Catalina (10.15.3), I was using the 10.15.2 I guess (or the previous of the one I installed). Since yesterday I can't open Photoshop 2020. As soon as I click on the icon the window of "unexpected quit" appears as you can see in the image (It's in Italian). I've tried to uninstall and install again the app and tried to install an old version of Photoshop (I'm currently using the 21.1) but nothing changes. Have anyone experienced the same? How do I solve this huge problem? I wanted to run the app through the terminal, maybe that could help, but I don't know how to.

Photo of Giacomo Frazzetta

Giacomo Frazzetta

  • 8 Posts
  • 1 Reply Like
  • frustate

Posted 5 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17063 Posts
  • 2904 Reply Likes
Official Response
This issue should be addressed by the 21.1.1 update. Let us know if you're still having trouble.