How can I use the GPU related Photoshop CS6 features?

  • 1
  • Problem
  • Updated 6 years ago
Can't use the "Lighting effects" in Photoshop CS6 (WIndows XP/32), probably because "Advanced" drawing mode greyed out. CS6's System Info reports "OpenGL Allow Advanced Mode: False." and "Video Card Renderer: GeForce GT 220/PCIe/SSE2". I installed the latest NVDIA driver (May 2012) for the GT220 video card.
Photo of Francois MESQUI

Francois MESQUI

  • 5 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
You need to upgrade to Windows 7. All GPU features are disabled on XP (drivers aren't getting updated, OS bugs aren't getting fixed, etc.).
Photo of Francois MESQUI

Francois MESQUI

  • 5 Posts
  • 0 Reply Likes
Wow! This is not the answer I expected. Thank you anyway for your prompt response.
Basically you're telling me that I spent 250€ to upgrade from CS5 to CS6 and that I end up with a tool that is less performing - and less stable btw - than the old one, with which I cannot use functions like "Lighting Effects" that worked with the early versions of Photoshop I used to work with ten years ago? And I would have to go through the pain and costs of installing a new OS on my computer to make these features of CS6 work?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
The requirements and release notes said that the GPU features don't work on XP.

But you are using an OS that is over 10 years old.
Photo of Francois MESQUI

Francois MESQUI

  • 5 Posts
  • 0 Reply Likes
OK, thanks, the problem is solved after going through the hoops of upgrading XP to Win7. I must admit that I do not read requirements and release notes before upgrading a product, in the secret hope that the existing functionalities still will work in new versions... Along these lines, following blog is misleading although it clearly recommends Win7 for PS CS6: http://blogs.adobe.com/photoshopdotco...

Again, many thanks, your advice was really helpful, except that the "Advanced" drawing mode can't be used otherwise images are not displayed properly (incomplete appearance) after loading that is described on the web. This is solved by setting the adjustment to "Normal".
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Glad you got it working.

If Advanced is causing artifacts (like you reported), then something is wrong in the shader support in your video card driver. Make sure you update your driver from the GPU maker's website (not Microsoft).