Photoshop: How to stop the Control/Command key from disabling snapping?

  • 1
  • Question
  • Updated 4 months ago
  • (Edited)
I've been trying to streamline my keyboard shortcuts and decided that I no longer need a shortcut for the "move" tool, because you can just hold down Control/Command to move objects. Great!

The only problem is that holding down Control disables snapping! I don't want snapping to be disabled!

Does anyone know a way to stop the Control key from disabling snapping?
Photo of Jim Ainsley

Jim Ainsley

  • 14 Posts
  • 7 Reply Likes

Posted 8 months ago

  • 1
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 285 Reply Likes
Hello, that is one of the functions of the Ctrl/Control key, it cannot be disabled.
Note that you do not have all the functions of the move tool while CMD/CTRL is held down: if you reinstate V, and click and hold, you will notice that the option bar does give you many options not available with CTRL. 
Photo of David Bleja

David Bleja

  • 48 Posts
  • 5 Reply Likes
Yes: just let go of Ctrl while you're moving the layer, and snapping should return. Once you ctrl-click on a layer, you no longer need to keep holding Ctrl, as long as your left mouse (or wacom pen) is still pressed. 

So, the process looks like this:

-hold ctrl to activate move tool
-click and hold on layer to auto-select it and start moving it
-release ctrl while still dragging layer, and layer should now snap again.
Photo of Jim Ainsley

Jim Ainsley

  • 14 Posts
  • 7 Reply Likes
David, thank you SO MUCH! All this time I have been keeping Ctrl held down. I can't believe the solution was so simple! Thank you!
Photo of Kukurykus

Kukurykus

  • 645 Posts
  • 159 Reply Likes
When 'Auto-Select' box is filled you don't have to use Ctrl, to drag any layer. When it's checked you need to hold Ctrl to drag layer. It's still helpful as with 'Auto-Select' you can select multiple layers, but when it's off then you can do other operations that was meant for (Select Move Tool to see it).
(Edited)