How to fully prevent photoshop to use integrated graphic processor at any point?

  • 1
  • Problem
  • Updated 2 weeks ago
some days ago a real nightmare started for me:

The canvas darkens a little bit and some blending modes doesnt work well, i have a two GPU on my laptop (Intel HD Graphics 620 and Nvidia GTX1050TI), i tried everything, first o lowered all the performance settings to the most basic thing, updated the drivers and indicated protohop to use high performance nvidia GPU from the nvidia 3d config panel, i made it as well from the display settings on windows 10 (For photoshop and the sniffer in both cases), but the problem just doesn't go away, if i disable one of my two graphic cards it works but i don't want to disable the integrated GPU because it controls every aspect of my screen, so if i disable it i can't change my MSI display setting with true color or change the screen bright, and i want to use the nvidia GPU with photoshop, if i uncheck the "use GPU" option in photoshop the problem goes away, but again, i WANT to use my nvidia GPU on photoshop, something i noticed is that even when i indicated everywhere in the system that photoshop has to work with the high performance GPU, on the system info of photoshop there's still the two of them, and as i have been reading on many blogs, it can cause issues as this one. Is there a way that i can absolutely disable the integrated GPU of photoshop as if it doesn't even exists on my computer? but ONLY for photoshop and the sniffer? i don't know what to do and i'm going crazy

my system info:

Adobe Photoshop Version: 20.0.0 20180920.r.24 2018/09/20: 1193433  x64
Number of Launches: 21
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.17134.1
System architecture: Intel CPU Family:6, Model:14, Stepping:9 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, AVX, AVX2, HyperThreading
Physical processor count: 2
Logical processor count: 4
Processor speed: 3 MHz
Built-in memory: 8108 MB
Free memory: 5181 MB
Memory available to Photoshop: 7402 MB
Memory used by Photoshop: 70 %
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Enabled.
Image tile size: 128K
Image cache levels: 4
Font Preview: Medium
TextComposer: Latin
Display: 1
Display Bounds: top=0, left=0, bottom=1080, right=1920
OpenGL Drawing: Enabled.
OpenGL Allow Old GPUs: Not Detected.
OpenGL Drawing Mode: Basic
OpenGL Allow Normal Mode: True.
OpenGL Allow Advanced Mode: True.
AIFCoreInitialized=1
AIFOGLInitialized=1
OGLContextCreated=1
NumGLGPUs=1
NumCLGPUs=2
NumNativeGPUs=0
glgpu[0].GLVersion="4.1"
glgpu[0].IsIntegratedGLGPU=0
glgpu[0].GLMemoryMB=2048
glgpu[0].GLName="NVIDIA GeForce GTX 1050"
glgpu[0].GLVendor="NVIDIA Corporation"
glgpu[0].GLVendorID=4318
glgpu[0].GLDriverVersion="25.21.14.1634"
glgpu[0].GLRectTextureSize=32768
glgpu[0].GLRenderer="GeForce GTX 1050/PCIe/SSE2"
glgpu[0].GLRendererID=7309
glgpu[0].HasGLNPOTSupport=1
glgpu[0].GLDriver="C:\Windows\System32\DriverStore\FileRepository\nvmii.inf_amd64_a9ee51aeea324fa8\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvmii.inf_amd64_a9ee51aeea324fa8\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvmii.inf_amd64_a9ee51aeea324fa8\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvmii.inf_amd64_a9ee51aeea324fa8\nvldumdx.dll"
glgpu[0].GLDriverDate="20181010000000.000000-000"
glgpu[0].CanCompileProgramGLSL=1
glgpu[0].GLFrameBufferOK=1
glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="4.60 NVIDIA"
glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[65536]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[4]
glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[192]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[32]
glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[32]
glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[4096]
glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[4096]
glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[124]
glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1
glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1
glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1
glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1
glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=1
clgpu[0].CLPlatformVersion="2.1 "
clgpu[0].CLDeviceVersion="2.1 NEO "
clgpu[0].IsIntegratedCLGPU=1
clgpu[0].CLMemoryMB=3243
clgpu[0].CLName="Intel(R) HD Graphics 620"
clgpu[0].CLVendor="Intel(R) Corporation"
clgpu[0].CLVendorID=32902
clgpu[0].CLDriverVersion="25.20.100.6326"
clgpu[0].CLBandwidth=1.25871e+10
clgpu[0].CLCompute=179.304
clgpu[1].CLPlatformVersion="1.2"
clgpu[1].CLDeviceVersion="1.2 CUDA"
clgpu[1].IsIntegratedCLGPU=0
clgpu[1].CLMemoryMB=2048
clgpu[1].CLName="GeForce GTX 1050"
clgpu[1].CLVendor="NVIDIA Corporation"
clgpu[1].CLVendorID=4318
clgpu[1].CLDriverVersion="416.34"
clgpu[1].CLBandwidth=9.13251e+10
clgpu[1].CLCompute=718.591
GUIDBucket:Composite Core (enable_composite_core): onComposite Core UI (comp_core_ui): offDocument Graph (enable_doc_graph): off
Application folder: C:\Program Files\Adobe\Adobe Photoshop CC 2019\
Temporary file path: C:\Users\CARLOS~1\AppData\Local\Temp\
Photoshop scratch has async I/O enabled
Scratch volume(s):
  Startup, 255,6G, 164,7G free
Required Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CC 2019\Required\Plug-Ins\
Primary Plug-ins folder: C:\Program Files\Adobe\Adobe Photoshop CC 2019\Plug-Ins\

Photo of Carlos Pisarello

Carlos Pisarello

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 2 weeks ago

  • 1

Be the first to post a reply!