Photoshop: How do I force Generator to generate assets?

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
  • (Edited)
Generator is the greatest thing I've discovered in Photoshop in a long time, and of course it continues my love hate relationship with Adobe product. I love it...when it works.

It seems very temperamental. Sometimes I just can't get it to generate assets. The Image Assets checkmark is checked and my file is all set up correctly, it just doesn't produce anything.

Sometimes changing layer comps triggers it to start working, sometimes I'll have to remove an extension in a layer name, then re add it, sometimes just reopening photoshop or the file itself gets it working.

Any tips on this? Is this a known issue? I'm actually dealing with a PSD right now that I can't get to generate assets no matter what I do, and I've quadruple confirmed that everything is set up correctly.

Thanks for any input.
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
Anyone?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14680 Posts
  • 1961 Reply Likes
Can you confirm what OS/version you're on?

I'll ask one the generator folks, but the most of them are out this week for the holiday.
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
OX 10.11 (15A284)

Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
Hi there...any updates on this? I'm still having issues with this in a number of files.

Thanks!
Photo of Ian Wehrman

Ian Wehrman, Employee

  • 5 Posts
  • 4 Reply Likes
Hi Elliott,
Photoshop engineer here! I’m sorry you're having trouble with Generator, and I’d like to help fix the problem.

First, can you tell me if you're still having the problem with the latest version of Photoshop CC (i.e., 2015.1, released on 12/1)? If so, can you email me (Ian Wehrman wehrman@adobe.com) a copy of your Generator log files? You can find the log files at /Users/[your username]/Library/Logs/Adobe/Adobe Photoshop CC 2015/Generator. Also, have you ever installed any other Generator plugins? Finally, if there is a particular PSD file that you think is causing problems with Generator, it would be helpful to look at that as well. Of course, I'll keep any files you send me confidential.

Thanks for your help, and sorry again for the trouble!
-- Ian
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
New version today? Great...updating now. Will report back.

Thanks!
Photo of Javier Corra

Javier Corra

  • 1 Post
  • 0 Reply Likes
I'm also having problems with Generator in Photoshop 2015.1 (I've updated yesterday, 12/1/2015). When I opened a PSD Im working with, some assets wheren't being generated properly, for example some layers that contain filters like drop shadow where exporting with the shadow cropped.

I notice that the assets that had problems were the ones that were invisible. Turning the visibility back on seem to fixed the problem.

I also had problems with other psd, it has "Generate->Image Assets" enabled but nothing was being generated. I had to go to the new preferences dialog, "Preferences->Plugins->Enable Generator" and turn it off and then back on, that got the generator working again.
Photo of Ian Wehrman

Ian Wehrman, Employee

  • 5 Posts
  • 4 Reply Likes
Javier: the same instructions I gave Elliott go for you too! Send me your logs, OS info, your list of other installed plugins, and ideally the PSD that's causing the problem. I'm wehrman@adobe.com. I'll keep everything you send me confidential!

-- Ian
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
Hi Ian,

Generator is running much more consistently now since the Photoshop update, but I am having the same problem as Javier where drop shadows are getting cropped. I'll email you my logs.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14123 Posts
  • 1761 Reply Likes
This is a great conversation that's separate from the main one, so I created a new conversation to continue the discussion.

Please reference the new conversation here: Photoshop: Drop shadows are getting cropped with Generator
Photo of Elliott

Elliott

  • 100 Posts
  • 5 Reply Likes
I still continue to have this problem periodically where generator just does not kick into gear so to speak after making design changes.

I've found deleting the extension on a layer and then re-adding it, usually gets it to start working. And if I'm working with layer comps, changing the selected layer comp also usually gets Generator to start.

But it seems like it should be automatic...no?