Elements 10: How to enlarge small icons and words?

  • 1
  • Question
  • Updated 2 years ago
  • (Edited)
I am using Photoshop Elements 10 with a new computer. All programs work well with screen resolution of 1920 and 1080 except Adobe. The icons and words are tiny and difficult to read. Enlarged font on display for computer, but no change in Adobe. How can I make words larger?
Photo of Jean Davis

Jean Davis

  • 5 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
What OS version are you using?
Photo of Jean Davis

Jean Davis

  • 5 Posts
  • 1 Reply Like
windows 8 windows 64 bit
Photo of Jean Davis

Jean Davis

  • 5 Posts
  • 1 Reply Like
My monitor goes up to 1920x1080, but will not allow me to select the increment of 1800x1100. Adobe Elements 10 looks best at 1280x720. I tried A 30 day free trial of Light room and a newer version of Adobe and could hardly read the tiny print so did not attempt to use.
I am thinking of purchasing a new monitor and will run into this resolution issue. I so appreciate your help. Two questions...
1) What is the ideal resolution on a 25 inch for Adobe Element 10?
2) What is the ideal resolution on a 25 inch for Light room?
Many thanks,
Jean
Photo of i riegner

i riegner

  • 2 Posts
  • 1 Reply Like
None of this helped.  I just want to enlarge the icons and text without all this other gibberish.  I have Windows 10.  I didn't have this problem before.  Maybe that's one reason I don't like to use Photoshop. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14333 Posts
  • 1844 Reply Likes
Looks like you're possibly on and old version (Elements 12) which doesn't support HiDPI systems. Current versions of Elements and Photoshop support scaling the UI and text 200%.
Photo of i riegner

i riegner

  • 2 Posts
  • 1 Reply Like
So how do I get a fix?
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1116 Posts
  • 233 Reply Likes
If you don't want to buy the current version, your only choice is to set the Windows preferences to a lower resolution for displaying fonts and menus.
Give it a try.