How do I avoid the context menus, when using my Wacom with Photoshop CC?

  • 1
  • Question
  • Updated 3 years ago
  • Answered
After re-installing Win 8 and Photoshop CC, I have a problem: a context menu pops up, when I try to use my Wacom Intuos stylus. How do I get rid of it? (I don't see where to do this in the Menus dialog.)
Photo of Quin Roberts

Quin Roberts

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
Sounds like you're pressing the side buttons on the pen when you try to use it, and one of the buttons you press is mapped to a right click (which shows context menus).

Either refrain from pressing the side buttons on the pen while using the pen, or change the mapping in wacom's settings to make the side buttons do nothing.
Photo of Quin Roberts

Quin Roberts

  • 2 Posts
  • 0 Reply Likes
Thanks for your input, Chris. However, it is not the side buttons that are triggering the context menu. It is the stylus tip. When I use Wacom Tablet Properties to Disable the side buttons, the problem persists. When I disable the tip, I cannot edit with the stylus. I haven't found a solution in the Windows pen settings, either.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
OK, that would mean that the wacom driver is set to send a right click event when the tip is pressed - which is really not a normal setting...

You probably need to contact Wacom and figure out how it is sending right click events (instead of normal, left click events) when the tip is pressed.
Photo of Kenneth Everett

Kenneth Everett

  • 2 Posts
  • 0 Reply Likes
I'm seeing the same behavior. Quin, please post a fix here if you've found one. I'll do the same if I find one from another source.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 768 Reply Likes
This was already covered above.

Go into the Wacom control panel, and turn off whatever button you have set to give a right click.
Photo of Kenneth Everett

Kenneth Everett

  • 2 Posts
  • 0 Reply Likes
Nope. Turns out Windows 8 has some Pen and Tablet settings which influence what happens when you press and hold the pen. The settings are there for tablet style comps. When I set my "hold" value to "long" the problem became less invasive. When I disabled the feature the context menus stopped popping up altogether. Thanks to Wacom support for guiding me to the solution.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 768 Reply Likes
Ah, ok, that's a new one to me (guess it's disabled on my system).