How can I disable the rotating circles telling me that photoshop is working and obfuscating my cursor?

  • 1
  • Question
  • Updated 8 months ago
  • (Edited)
why do I need those rotating circles telling me that photoshop is calculating when I am, as an example, erasing something? I need to see the edge of the curser and this animation starts up replacing my cursor - who had the brilliant idea for this gimmick that is not only useless but actually interfering with getting things done - I know that photoshop is erasing - can I please see my cursor and what is being erased? 
Photo of roadie

roadie

  • 5 Posts
  • 1 Reply Like

Posted 8 months ago

  • 1
Photo of roadie

roadie

  • 5 Posts
  • 1 Reply Like
... I just checked and neither Gimp or Pixelmator have this glitzy animation. I don't want to be unkind but does it not seem ridiculous to have this animation running using processing power to indicate that processing is taking place and actually making it impossible to see the exact cursor outline? 
Photo of David

David, Official Rep

  • 3285 Posts
  • 525 Reply Likes
Hi Roadie,

Uh, I'm not quite following you.  You're seeing an animated cursor when using the Eraser tool on pixel data?  I don't understand the application state that you're talking about.

What OS are you running?  Which version of Photoshop?  What precisely are you doing?  Open a doc and then...?

Thanks,
David
Photo of roadie

roadie

  • 5 Posts
  • 1 Reply Like
Hi David,
yes - exactly. (macos mojave)
I am using the eraser in photoshop 2014 (but my wife has the same animation in the most recent CC). I erase with the eraser brush and the outline of the cursor (size of the brush) starts to have animated circles (like those flash or website loading spinners) while moving the brush / eraser. And I cannot see a purpose they serve except for telling me "look, I am calculating ..." I hope that makes it clear - otherwise I can make a video. :)
... and I did - does this make it clear what I mean with animated circles? If you don't have that let me know how to turn it off. Thank you so much.

(Edited)
Photo of David

David, Official Rep

  • 3188 Posts
  • 504 Reply Likes
Howdy Roadie,

Ah, now I understand.  Thanks.  That ain't Photoshop.

Your OS is telling you that it's taxed and processing something.  This might be because PS 2014 is probably not optimized for the new OS.  Why don't you upgrade to the current version?  I am not seeing this on any of my Mac OSes with the current version of the product.

If you really can't update your version, I would then make sure as many system resources were free as possible, including closing all other apps you can and making sure that you have plenty of scratch space.

Hope that helps,
David
Photo of roadie

roadie

  • 5 Posts
  • 1 Reply Like
Howdy Dave, it does not sound as if you understood that this happens on the current Photoshop CC my wife is running too. That would be one reason not to upgrade. 
The other reason is that I fixed it by going into system preferences and checking this little checkbox. Youtube provided the solution. It now works with 5 other programs running, internet connection and keyboard light on. Thanks for your input.


Have a lovely day,
Roadie
(Edited)
Photo of David

David, Official Rep

  • 3188 Posts
  • 504 Reply Likes
Howdy Roadie,

I really don't know what to tell you.  I checked with the latest version as well as the previous two major releases.  The control which you disabled to "fix" the problem actually doesn't exist since at least 2017.  I'm not sure what the five year old functionality is that you're running afoul of, but, again, the best solution is to update to a version of the application that's actually designed to run on the OS which you're using.  Mojave is almost brand new.  Photoshop CC 2014 is quite old.  A mismatch isn't surprising, much as pumping today's gas into an Edsel might trigger issues -- application software is optimized for the OS on which it runs and even Microsoft and Apple make no guarantees about software more than two major releases old.  You're talking more than double that at five years...

Either way, the cursor that you are encountering is a result of the OS believing that it's running outta resources and that it needs to slow down real-time events.  This could be triggered by SOME OTHER application which you have installed that's trying to help you with reading or otherwise displaying data.  Heck, you might be low on scratch disk space or system resources.  It might even be a piece of hardware not behaving.  But whatever the case, I've now tried on three different machines trying nearly every release since 2017 (inclusive) and I don't see either the problem, nor your solution, so there's at least one more, element at play here.

To really help address your situation, I'm going to need more information from you, including the other apps you're running and your system setup.  Or, just update Photoshop, cuz I haven't heard a single report like yours, so it's almost certainly some mismatch or disconnect.

Thanks,
David
Photo of roadie

roadie

  • 5 Posts
  • 1 Reply Like
Thank you so much for the help. True, it was quite hard to find a Macos that still has the system preferences > security & privacy > privacy > accessibility tab but I did manage and then I was able to check that little box. I have also bought a usb-4 stick with 16GB to use as Scratch Disk Space and this helped too. In fact as I wrote in my previous post it now works flawlessly.
Now I would love to help you get that functionality into your new Mojave but you have to be aware that it is always risky to run bleeding edge software. In general you have to wait about 5 years for any kind of software to have all the bugs and glitches fixed so that it is usable in a production environment. While I understand the attraction of always running the latest and greatest OS and Photoshop Version, there are downsides so I would advise you stop trying to get the spinning ball feature and wait for a major bug release to address the issue.
It has been fun talking to you and I appreciate the help and information you have provided. I see much clearer now.

Thank you and have a lovely day.,
Roadie