Photoshop: No tool display, images not loading right...

  • 2
  • Question
  • Updated 4 years ago
  • (Edited)
Help! I want my PS back! Since the most recent update nothing is working correctly.. when opening a photo it creates its own window, instead of displaying inside photoshop? The only way to fill the space is to click arrange>tile horizontal. But every time??

WORST of all, I cannot see the tool display? Dodge/burn, healing brush, clone, brush.. nothing?? No size or preview? Help! I can't work like this! It seems like there must be an easy fix (like choosing classic mode on the awful crop) but I can't find it!
Photo of Ann Beck

Ann Beck

  • 4 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Which update?
Which specific version of Photoshop are you using?
Which OS version?

Can you show us a screen shot of what you are referring to?
Photo of Ann Beck

Ann Beck

  • 4 Posts
  • 0 Reply Likes
It just started in the last week or so, so whatever the most recent update is?

I have PS 14.1.2, Windows 8.

I tried to take a screenshot but it doesn't show the cursor, which is what my issue is with. For example, if I have the clone tool selected, I used to see a circle in the pixel size selected or a + if the capslock was on.

Now, I only see a tiny icon of the clone tool next to the arrow, or the same + sign with the capslock.

This is happening for almost all of the tools.. burn, brush.. I can't see the circle (or with the brush, the preview of the brush shape) I can only see the icon next to the arrow.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Please download the updates. for Photoshop CC you should have version 14.2.1, or 15.0 (CC 2014).

Cursors not showing correctly is a frequent symptom of video card driver bugs.
Check your GPU maker's website for updated drivers.
Photo of Tony Brookshire

Tony Brookshire

  • 2 Posts
  • 0 Reply Likes
Okay, We have the Microsoft Windows 7 pavillion
Photo of Tony Brookshire

Tony Brookshire

  • 2 Posts
  • 0 Reply Likes
okay! We will look into this. Thank you for your feed back.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Microsoft makes Windows, they don't make laptops.
HP makes something called a pavillion.
But none of that relates to your video card / GPU. And you need to go to the GPU maker's website to get up to date drivers (MS and HP have drivers that are years out of date).
Photo of Ann Beck

Ann Beck

  • 4 Posts
  • 0 Reply Likes
I was able to fix the images opening in new windows thing by going into my preferences and changing to open new image in tabs. But I cannot find anywhere to change this setting back, and like I said it all just started happening recently, I have not changed anything on my end so I assume it was with the new update.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
No, none of that has changed in any update. It had to be a change made by a user on your system.
Photo of Ann Beck

Ann Beck

  • 4 Posts
  • 0 Reply Likes
I am the only user on my system and I have not made any changes. I was only able to find the tab setting after two hours on different photoshop forums and help boards. It is not something easily changed and I am certain I did not do it.

I downloaded the newest version of photoshop and checked my video card, all is current and working fine, I still see the arrow with the tool, not the circle.