Photoshop: Hebrew text is backwards

  • 1
  • Problem
  • Updated 9 months ago
  • Solved
  • (Edited)
I tend to work with text a lot in my designs. I am working on a project that uses Hebrew. When I got the document back in hebrew I copy and pasted the text into photoshop. Photoshop rearranged all the letters and the words... is there a way this can be prevented. I have never had copy paste screw up like this before.
Photo of Shem Arnold

Shem Arnold

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Official Response
Shalom Shem,

In Photoshop, to correctly render right-to-left (and complex) scripts, you need to change the composer to the Middle Eastern/South Asian one. You do that under Preferences > Type. You can get the full details from my video: https://www.youtube.com/watch?v=gfuw7m...

Toda!
David
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Official Response
Also, once you have the MENA (Middle East and North African) composer active, you can go to Type > Language Options > Middle Eastern Features and you will have an option in the Paragraph Panel to control the flow of any text.

Thanks,
David