Lightroom CC 2015: HDR merge, turns filters off

  • 2
  • Problem
  • Updated 2 months ago
  • (Edited)

This conversation has been merged. Please reference the main conversation: Lightroom CC removes your filters when Photo Merge tools complete processing

In Lightroom CC 2015.2.1 while filtering on a color, merging HDR will after it's combined have you go back to view with "Filters Off". Might be by creation, or a bug. Seems to be a strange thing to do.
Photo of Teeby


  • 3 Posts
  • 0 Reply Likes
  • Frustrated

Posted 2 years ago

  • 2
Photo of erikhill


  • 1 Post
  • 0 Reply Likes
I'm having the same issue with photo merge/panorama.. super annoying..
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 2920 Posts
  • 418 Reply Likes
erikhill, If you go to Help>System Info... what is your exact Lightroom version? 

Can you give me step by step instructions and what you are seeing and what you expected to see so that I can attempt to duplicate?
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 70 Reply Likes
This is by design, since otherwise (depending on filter settings) you could end up being unable to see the pano or HDR merge that you’d just made.
Photo of Olafur Haraldsson

Olafur Haraldsson

  • 21 Posts
  • 1 Reply Like
If this is by design this is amazingly bad design decision. This is driving me off the wall here. I understand your thoughts of some absolute beginner user would not find the HDR that was created but come on, this is a feature to be used like this.

Can you please please fix this, this is a clear bug not a by design thing.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 755 Posts
  • 273 Reply Likes
If Adobe says it's by design, then it's by design. I agree that it's poor design, however. Especially because merging color labeled images (otherwise you wouldn't see them due to the filter) results in a panorama/HDR with the same color label anyway...
Photo of John R. Ellis

John R. Ellis, Champion

  • 3165 Posts
  • 761 Reply Likes
To stop the filter from getting reset, make sure File > Library Filters > Lock Filters is checked.  (Alternatively, click the lock icon on the right end of the Library Filter bar.)

See here for a description of Lock Filters:

This conversation is no longer open for comments or replies.