Lightroom CC 2.2: HDR merge getting stuck at 100%

  • 3
  • Problem
  • Updated 2 weeks ago
  • Solved
  • (Edited)
Hi,

Im trying to complete a HDR merge on Lightroom CC (Ver 2.20) using a stack of 3-5 images. When I select the option to merge the images, it goes to the next screen where a loading bar shows "Gathering Data..." This bar reaches 100% and then seems to stay on this screen permanently. I've waited upwards of 20minutes and nothing has happened, it remains showing the same loading bar. 

Can you please recommend anything I'm doing wrong or any potential fixes? 

Im working on a MacBook pro (2013) 2.9GHz I7 processor, 8GB RAM and a Intel HD Graphics 4000 1536 MB card.

Kind regards,

Lewis
Photo of Lewis Guy

Lewis Guy

  • 1 Post
  • 0 Reply Likes

Posted 6 months ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15531 Posts
  • 2315 Reply Likes
Hi Lewis, does this happen with all sets of images you try to merge? Or just a specific set? If a specific set, can you zip them up and post them for us to download and troubleshoot?
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
Same thing, version 2.3, no specific set of pictures, it happens mostly on all of my stacks.
In my case it is stuck on "Gathering Data... 100%".
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
I am sorry to hear that the 2.3 update didn't fix the issue for you. At this point, we would need to get a few sample files from you that fail so that we can test with your files. Are you willing to share files with us?
Photo of Kirill Konshin

Kirill Konshin

  • 13 Posts
  • 1 Reply Like
I'm OK to share files with you, no problem.

https://www.dropbox.com/s/quh770y1uzffsm8/Lightroom%20bug.zip?dl=0
https://www.dropbox.com/s/fefg5zvdbtyn0vm/Lightroom%20HDR%20bug.zip?dl=0

Separate issue is that Lightroom CC fails to merge HDR panorama, it says images are not HDR panorama. Lightroom CC Classic has no problems merging both.

I can also share part of my online library somehow if that would help.

But like I said in another thread https://feedback.photoshop.com/photoshop_family/topics/panorama-merge-stuck-at-100, panorama has stopped working for ALL images, even for those that were working before I made library bigger. When I had like 100 images it was fine. Now I have few thousands and it's stuck.
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Any update? I have the same identical issue, with Lr CC 2.3. I cannot merge any AEB bracketing at the moment.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
Kirill, 

I tested with your files (thank you for those) using Lightroom Desktop 2.3.  I was able to successfully merge an HDR, a Pano and an HDR/Pano from your files with no issues.

I would recommend you reset your preference file and try again.  If that doesn't cure it you may want to do a clean install of the App. 

Preference File reset:

A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?

Clean Install:

Close Lightroom
Restart the computer
Use the Adobe Creative Cloud App to uninstall Lightroom
Restart the computer
Install Lightroom  via the Creative Cloud App without launching any other programs.
Restart the computer
Launch Lightroom
Wait 5 minutes

I am going to post these same instructions into your other thread. 
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
I carefully followed all the steps, but HDR merge is still stucking at "gathering data 100%".

macOS 10.14.3
Lightroom CC 2.3

I'm still using Lr basically for merging aerial panorama/HDR photos, very annoying I cannot use this function.
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Ok, I found the root of the problem:
I usually stack AEB photos, and if I right click on a stack and then choose "Photo merge -> HDR merge" I stuck at 100%.
If I don't use stacks, photo merge works well.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
If you click on the stack the contained images should appear in a film strip below. If you then click on the images in the film strip to select all in the stack, does that work?
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Filmstrip is only in the edit view, and also show me images stacked. I can right click -> photo merge from there, but the result is the same.
At the moment, the only way to get photo merge to work is to unstack photos, select them and merge them.
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
Click on the Stack badge in the upper right of the thumbnail.  A filmstrip should appear of just those images in the stack. Select them in the film strip and attempt your merge. 

Results?
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Ok, in this way it works. I didn't know I can open the filmstrip clicking on the badge.

However, if there is a "Photo merge" entry in the stack context menù, it should work as expected.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
I spoke to the engineer for this and he agrees it should work (used to work from) the collapsed stack thumbnail. We've logged a bug for this. You have a couple of workarounds in the thread so you aren't dead in the water!
Photo of Stefano Giraldo

Stefano Giraldo

  • 7 Posts
  • 0 Reply Likes
Yes, thank you for feedback!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5797 Posts
  • 1259 Reply Likes
Lightroom Desktop 2.4 was released today and contained a fix for this issue. Please update to 2.4 and verify that you are no longer seeing the issue. Thank you!