Photoshop: CS6 polygonal lasso tool auto-completes unexpectedly

  • 9
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
Having issues with polygonal lasso tool.

When in mid selection, the dotted line disappears - though I am able to continue making a selection, the selection seems to jump and completes itself. Also, when plotting multiple points around rounded edges, it completes the selection, as if I were to double click. The plot points are far enough away, so this should not happen.

Furthermore, when I try the "Add to Selection" feature of the tool, I make a selection to add to the areas that were affected with the above issues, it seems I am adding to the selection, but when finished, nothing happens. This feature is not working altogether.

Other than those issue, I love the new CS6 creative suite. Nice improvement and a valuable arsenal of tools for my daily tasks :)
Photo of Paul Boyle

Paul Boyle

  • 1 Post
  • 0 Reply Likes
  • slightly frustrated

Posted 8 years ago

  • 9
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16272 Posts
  • 2583 Reply Likes
Official Response
Please try the solution in this document:

http://helpx.adobe.com/photoshop/kb/p...

Installing the plug-in from the document above should solve:

• menus, panels, or dialog boxes turn white and become unresponsive
• keyboard shortcuts stop working
• lasso tool selections close prematurely
• Photoshop becomes unresponsive

Let us know if this solves your issue.
Photo of Emil Assarsson

Emil Assarsson

  • 10 Posts
  • 0 Reply Likes
Sweet! Thanks a bunch Jeffery :-)

Note: This is an _updated_ (1.0.6) whitewindow plugin.
Photo of Fernando Bencomo

Fernando Bencomo

  • 1 Post
  • 0 Reply Likes
I'm on a mac pro 10.9.3 Adobe CC and i have the same issue, totally annoying that you guys haven't fix this.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 851 Reply Likes
Try using CC 2014, or install the plugin in CC to work around some of the known MacOS bugs.
Photo of jake myler

jake myler

  • 12 Posts
  • 3 Reply Likes
What happens when you get this problem on a PC? This is a solution for MAC only. Furthermore it's a pluging that was integrated into Photoshop a while ago so this solution is defunct. 
Photo of Anmari Linardi

Anmari Linardi

  • 6 Posts
  • 1 Reply Like
I realize this posting is old but I just tried this today and it seems to have fixed the issue on a Mac running 10.12.6 using PSCC 20.0.7 with an Intuos Pro Wacom PTH-651 tablet. So far, so good. Just remember to restart after installing the plug-in. Good luck!