Photoshop: Using the hand tool the field of view will move automatically (usually to the left)

  • 4
  • Problem
  • Updated 6 years ago
  • In Progress
  • (Edited)
Using the hand tool (both while hand tool is selected or space bar shortcut is held), sometimes my field of view will move automatically (usually to the left). It happens almost at-random but is very very frustrating.
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 4
Photo of iMatt

iMatt

  • 122 Posts
  • 10 Reply Likes
Hi Ryan-
I was having a similar issue for a while, and found it to be that the surface I was mousing over was not neutral enough. I would recommend you clean your mouse, and get a solid color mouse pad.
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
I do have a new mouse. My mousepad is a solid color. My mousepad is also very opaque. Thank you.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Hi Ryan, it sounds like you may be encountering the Birds Eye View feature:

http://feedback.photoshop.com/photosh...

Is this what you are seeing? Does disabling OpenGL make the problem go away?

Additionally, are you using a tablet?
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
Good solution. Your help led me to disable "Flick-panning" which seemed to be my problem's culprit. I do not use a tablet by the way. I can now use OpenGL drawing with my problem solved. Thank you, yes!
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
On top of that, you did help me find "Birds-eye-view". My school and I failed to ever swarm such a feature. Now, I think it will be second-nature when spot-healing!
Photo of Jeanne Rubbo

Jeanne Rubbo, Employee

  • 125 Posts
  • 27 Reply Likes
Hi Ryan,

In addition to Jeff's questions, do you have a Flash panel (such as Mini Bridge) open when this happens?
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
Jeanne Rubbo, I can assure you my Mini-bridge was closed all while my problem existed. I do not know which other panels use "Flash", but panels that were open are: Adjustment, Info, Layers, Swatches, and Tools.
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
How to cause my problem:

Flick-pan enabled.

[When zoomed in]
1. Either Hand-tool or space-bar a click&drag and move your field-of-view (do not release button)
2. Tap Apple's Magic-mouse with a second finger (forcefully), then release click&drag.

A sudden "jump" in navigation occurs roughly once every half dozen click&drags. Sometimes it happens much more consistently. I hope someone else can re-enact this scenario.

I find my instructions above prove finicky results. Understandably this problem does not make complete sense.

Some other information about my system and/or variables (just in case):
OS X Lion Ten.Seven iMac with Photoshop Creative Suite Five
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Can you try a different mouse? Your magic-mouse might just have a glitch, which causes Photoshop to think you flicked the document (yeah, I turn that off as well).
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
A different mouse is great. Flick Panning was the culprit, i.m.h.o. Flick Pan and my Magic Mouse may get along in future Photoshops-- not that I personally miss that feature anyway.
Photo of domellen

domellen

  • 2 Posts
  • 0 Reply Likes
I have exactly the same problem but it happens very very often, not every time, but almost. It does this with the magic trackpad, with my old two button + scroll button mouse, with my Logitech Marble Mouse, but not with the Wacom tablet.

When I click and drag to move the field of view then release, the image floats away, usually down and to the right. I have tried disabling "scroll with inertia" but it doesn't change anything.

To stop the motion I have to click again very quickly on the moving image but even this doesn't work every time. Very annoying.

PowerMac early 2008, Mac OS X 10.7 Lion, Photoshop CS5 12.0.4 x64
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
Do not "Enable Flick Panning" under "General" in Photoshop's preferences.
Photo of Tim

Tim

  • 2 Posts
  • 1 Reply Like
I'm having this trouble with my magic mouse, too.. I call it the elastic band effect, because I bring the page to a stop after flicking, and on mouse release, it flies off the screen!

I believe it began in CS5.5 - I can't quite remember it in CS5, certainly not in CS4 (obviously - no flick panning!).

I hit space and drag, and regardless of the order I release (mouse button / spacebar first). I've also made very sure that I'm not accidentally touching the surface with another finger.

Its intermittent in the sense that I can't make it happen every time, but it certainly is plaguing every design session! (I'd agree with the 1 in 6 estimate made above).

Turning off flick panning seems to work, but I miss it! I don't have any flash panels visible (to my knowledge - they're all oldskool panels).

Macbook Pro 10.7.2, Adobe CS5.5 (PS v12.1), Magic Mouse
Photo of Ryan von Schwedler

Ryan von Schwedler

  • 9 Posts
  • 0 Reply Likes
I would call this problem resolved. It seems this problem is in their court. I trust them and am grateful enough for how great this product remains to be since its inception. Be happy you can use your awesome mouse with it after all!
Photo of Tim

Tim

  • 2 Posts
  • 1 Reply Like
hmm.. I'm grateful for PS - its a fine product. "this problem is in their court" doesn't equate to resolved. Turning off flick panning is a workaround, not a fix.

My magic mouse has worked flawlessly with PS, and I see my posts as a contribution towards the continued evolution of PS.

Thanks for your attention ;)