Photoshop: Group linear dodge may acts different from the layer linear dodge

  • 2
  • Problem
  • Updated 6 days ago
  • Solved
  • (Edited)
Hi everyone. I found that when choosing group blending mode as linear dodge, it would act in a differently from simply apply a linear dodge layer. An example:

 


Upper one the adjust layer, lower one the 'adjust group'. (in case these helps: Layer 1 consists of deep blue& white, the two layers are white rectangles blurred using Gaussian blur.)


The group only contains one layer in normal mode which has identical pixels as the adjust layer does.

Same thing happens for color dodge mode, but not for lighten, screen and lighter color. Seems blending type related.

 

Searched for blending methods and group blending mode, but came to that in this case they should work in the exactly same way... Did I missed or misunderstood anything? 

This is a quite interesting feature but I'm curious about the mechanism.

Thanks in advance.
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Which specific version of Photoshop are you using?
Which OS version?

Yes, the blend modes should behave the same way, but some of the behavior depends on precisely what settings you have applied to each layer and group.
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes
CC2015 and OS X 10.10.5 yosemite, running on a macbook pro with retina. Didn't test for other PS versions yet.
I posted in general forum too and there found that if we turn off the "Transparency Shapes Layer" in the Layer Style, the adjust layer would work as the linear dodge group does. Did some further search but still lost. Groups  have the checkbox on for default, layers too.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Have you installed the 16.1.2 update?

We'd still need to see the PSD document to check all the structure options...
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes
Not yet. Actually I was following a tutorial posted at least 2 years earlier and found this behaviour in step4... note that the author used this 'feature' on purpose (with no explanation).
Here's a sample PSD doc, hope it helps.
(Edited for a typo)
(Edited)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 842 Reply Likes
Ok, we have the file and will take a look.
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes
Thanks a lot!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Official Response
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes
Thanks for the replay and fix! 
Photo of PECourtejoie

PECourtejoie, Champion

  • 795 Posts
  • 288 Reply Likes
A user reported a similar-looking bug on the adobeforums, with 2017.1.1 : https://forums.adobe.com/thread/2376283
Photo of roboeast

roboeast

  • 1 Post
  • 0 Reply Likes
This issue still exists. It is not fixed in the current version of Photoshop CC 2018 19.0 release. Color dodge only works if applied to a layer and you uncheck "Transparency Shapes Layer". It will not work at all if you apply the Color Dodge to a folder.
Photo of Xiaowen Feng

Xiaowen Feng

  • 6 Posts
  • 0 Reply Likes
It's been like 2 years and this issue still hangs on somehow (just a few seconds ago I got a email where a comment said it's not fixed even in 20.05 and had been broken since 7 ??)... I sorta regret that I didn't test the fix and follow up more properly back then.

I'm not a active photoshop or forum user, but this doesn't sound good. Can we re-open this issue by any chance? If anyone would be willing to submit a new ticket, please feel free to use or refer to stuffs I described here, many thanks.
(Edited)
Photo of JEA

JEA

  • 347 Posts
  • 200 Reply Likes
Apparently there is still an issue with this in photoshop 20.0.5 as demonstrated here:

https://forums.adobe.com/thread/2634249


It's easy to replicate the issue in photoshop 20.0.5

 

1. Make a new document in sRGB, fill with 50% grey.

 

On the grey layer use a soft brush set to white and Linear Dodge (Add) in the tool options bar

 

2. Make a new layer, paint on that layer with the same white brush and then change the layer   blend mode to Linear Dodge (Add) and uncheck Transparency Shapes Layer in the Layer Style Blending Options.

 

blend-3png

 

3. Make a new layer, put the layer in a Group, paint with the white brush on the layer in the group. Then change the Group Blending Mode to Linear Dodge (Add). Now here's the problem that even if you uncheck Transparency Shapes Layer for the Group it still doesn't match the other two, assuming the other two is how it's supposed to look.

 

blend-1png

 

You can fix the group by filling layer 2 in the group with Black in the Behind blend mode, but for some other blend modes the fix is not so easy or it might not work on a particular document for whatever reason.

 

blend-2png


After further investigation it actually looks like the bug has to do with the Fill Opacity on Groups.

 

If you check Transparency Shapes Layer and reduce the Fill Opacity to 99 then it looks like the other two layers.

 

blend-4png



(Edited)
Photo of JEA

JEA

  • 347 Posts
  • 200 Reply Likes
This post has another file for testing:

https://forums.adobe.com/thread/2634249