Lightroom Classic 8.4: GeForce GTX 750ti - Graphics Card not supported

  • 7
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
I just upgraded from LR 8.3.1 to 8.4 and support for my Graphics Card
acceleration seems to have disappeared. I'm sure it was working under previous version but under Edit/Preferences/Performance, the graphics acceleration is now marked as "off" with a message that my system isn't supported. Checking out the list of Graphics cards it seems that my GeForce GTX 750ti card is now no longer supported by latest LR version. So, the promised improvements in performance that I've been waiting for aren't available to me unless I shell out for a new card - unless of course any helpful soul on here can point me in the right direction please? It's also worth noting that the graphics card IS supported in the latest version of Photoshop CC.
Photo of Nigel Dalton

Nigel Dalton

  • 15 Posts
  • 2 Reply Likes

Posted 3 months ago

  • 7
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6186 Posts
  • 1370 Reply Likes
Official Response
Lightroom Classic 8.4.1 was released earlier today and has a fix for this issue. Please install the update and let us know if you are still seeing this issue. 

Also read this for more important information regarding an upcoming change to OpenGL Support: http://blogs.adobe.com/crawlspace/2019/08/changes-to-os-and-graphics-processor-gpu-support-in-adobe-camera-raw-lightroom-classic-and-lightroom.html

Thank you for your patience!