Lightroom Classic: GPU rendering will not complete in Develop Mode at Fit/Fill zoom levels

  • 6
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
Using LR Classic CC 7.3, I've encountered a new problem.  When scrolling through photos in the Develop Module, GPU Rendering will not work at either Fit or Fill zoom levels.  The progress circle in the bottom right spins indefinitely.  When I zoom to 1:1, 2:1, etc., the photo renders almost instantly, which is what I'm used to.  

This happens for every photo, every file type.  Zooming to 1:1 always fixes it.  
Photo of Justin Elledge

Justin Elledge

  • 30 Posts
  • 2 Reply Likes
  • frustrated

Posted 10 months ago

  • 6
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4868 Posts
  • 990 Reply Likes
I haven't seen that issue, Justin. Let's get some info from you. What is your OS? Version? 
Graphics Card? Driver version?
Photo of Justin Elledge

Justin Elledge

  • 30 Posts
  • 2 Reply Likes
OSX 10.13.4
AMD Radeon R9 M395X

I may be mistaken, but I don't think there's a way to check the graphics card driver version on OSX.  I think it's just part of the system update.  Is that correct?
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4868 Posts
  • 990 Reply Likes
Correct. If you had ended up being a Windows user, you would have a driver you could check/update independently.  Have you tried the 7.3.1 update yet?
Photo of Justin Elledge

Justin Elledge

  • 30 Posts
  • 2 Reply Likes
I should have updated my question.  I just switched to 7.3.1, and the problem remains.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1539 Posts
  • 497 Reply Likes
Do you have the Lightroom preference setting "Lightroom>Preferences>Performance>Use Smart Previews instead of Originals during image editing" turned on?

If that is the case and the spinning icon does not go off, it is an indication that you don't actually have the Smart Previews generated for those photos. This is a known issue and will be fixed in the next Lr update. 

For now, you can ignore the spinning icon for this case, it is a false alarm. Alternatively, you can force the Smart Previews to be generated ahead of time when turning on such preference settings.
(Edited)
Photo of Justin Elledge

Justin Elledge

  • 30 Posts
  • 2 Reply Likes
Bingo!  That's exactly it.  Thank you, Simon and Rikk.
Photo of Sven Kohle

Sven Kohle

  • 63 Posts
  • 41 Reply Likes
It may be the same issue I observed in different flavours also on latest OsX HighSierra and LR 7.3.1. Though it does not depend on GPU acceleration. I observe the issue in many cases (but not always), mostly after having done multiple view switches and editing. Mostly I don't see the spin icon though. I had it once and then finally LR froze. Usually I can continue working but I am keeping zooming in/out to get an updated view.

My machine setup:Lightroom Classic version: 7.3.1 [ 1167660 ]License: Creative Cloud
Language setting: en-DE
Operating system: Mac OS 10
Version: 10.13.4 [17E202]
Application architecture: x64
Logical processor count: 4
Processor speed: 3,2 GHz
Built-in memory: 24.576,0 MB
Real memory available to Lightroom: 24.576,0 MB
Real memory used by Lightroom: 8.419,8 MB (34,2%)
Virtual memory used by Lightroom: 18.444,2 MB
Memory cache size: 1.511,1MB
Internal Camera Raw revision: 933
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 2387MB / 12287MB (19%)
Camera Raw real memory: 2433MB / 24576MB (9%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: NVIDIA GeForce GT 755M
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1539 Posts
  • 497 Reply Likes
The spinner is only relevant when the GPU acceleration is turned on. You don't always see the spinner if the image loading completes quickly. There is a set delay timer to trigger the spinning icon to display. If image loading completes before the delay timer fires, there would be no spinner shown. 

Does the Lr freezing part happen when the GPU acceleration is turned off?
Photo of Louis Vallance

Louis Vallance

  • 5 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled [7.3.1] Images to not render correctly unless zoomed in and back out again.

Hardware environment

CPU: Intel Core i7-3770K
GPU: MSI NVIDIA GeForce GTX 670 (391.35)
RAM: 16GB

Software environment

Windows 10.0.16299
Lightroom Classic CC 7.3.1

Problem description

After updating to Lightroom Classic CC 7.3.1, images to not load correctly:





Workaround

Zoom in and then out again:



Disabling the graphics processor does not solve the problem: Edit → Preferences... → Deselect "Use Graphics Processor".

Updating to NVIDIA driver 397.64 does not solve the problem.

Testing description

Reproduced in Lightroom Classic CC 7.3.1. Issue can be reproduced reliably upon restarting the computer.

Best regards,

Louis Vallance
Photo of Sven Kohle

Sven Kohle

  • 63 Posts
  • 41 Reply Likes
I guess it is the same problem as I described, and this cannot be fixed by the config item "smart preview" - see my observations here: https://feedback.photoshop.com/photoshop_family/topics/lr-7-3-1-often-not-updating-rendering-in-full...
Photo of Mads Eneqvist

Mads Eneqvist

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom never renders photo..

When making adjustments to photos the spinning "wheel" in lower right never stops and the photo does not render. 
I've found a workaround which is to zoom in while rendering. Then the photo renders 100%. 
Tried several things to try and solve this but without any luck. 
Please help!
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4868 Posts
  • 990 Reply Likes
Official Response
Lightroom Classic CC 7.5 was released today and should address this issue.  If you don’t see the update in your Creative Cloud App, hit the [Ctrl/Cmd]+ [Alt/Opt]+[R] to force a refresh. 

Give the new version a try and let us know if it solves the issue.