Lightroom Classic: GPU rendering will not complete in Develop Mode at Fit/Fill zoom levels

  • 3
  • Problem
  • Updated 1 week ago
  • Acknowledged
  • (Edited)
Using LR Classic CC 7.3, I've encountered a new problem.  When scrolling through photos in the Develop Module, GPU Rendering will not work at either Fit or Fill zoom levels.  The progress circle in the bottom right spins indefinitely.  When I zoom to 1:1, 2:1, etc., the photo renders almost instantly, which is what I'm used to.  

This happens for every photo, every file type.  Zooming to 1:1 always fixes it.  
Photo of Justin Elledge

Justin Elledge

  • 27 Posts
  • 2 Reply Likes
  • frustrated

Posted 4 weeks ago

  • 3
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1377 Posts
  • 408 Reply Likes
Official Response
Do you have the Lightroom preference setting "Lightroom>Preferences>Performance>Use Smart Previews instead of Originals during image editing" turned on?

If that is the case and the spinning icon does not go off, it is an indication that you don't actually have the Smart Previews generated for those photos. This is a known issue and will be fixed in the next Lr update. 

For now, you can ignore the spinning icon for this case, it is a false alarm. Alternatively, you can force the Smart Previews to be generated ahead of time when turning on such preference settings.
(Edited)