Photoshop Elements: PSE 9 prints blank pages (Mac/Epson Artisan 50)

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
I recently bought an iMac specifically to use with my photographs, and installed Photoshop Elements 9 (a Mac-compatible version) on it. I've enjoyed using Elements for several years on my PC, and have gotten used to using it to process my pictures.

But I can't print any pictures from Elements! Pictures print from iPhoto, but, when I use Photoshop, the photo paper goes right through the printer and comes out blank. I thought perhaps it was something to do with the new Epson Artisan 50 printer that I installed on the Mac, so I also installed the Canon printer, that I have successfully used with Photoshop on my PC, onto the Mac - and the same thing happens. I don't know if it's a quirk with the Mac or with the Mac-compatible version of Elements 9 I'm using, but I'm getting REALLY FRUSTRATED!!!

Any ideas, anybody?
Photo of Elizabeth Trevenen

Elizabeth Trevenen

  • 1 Post
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Gaurav Jain

Gaurav Jain

  • 3 Posts
  • 0 Reply Likes
I am assuming that Printer drivers are all updated but just to double check can you please try updating once and check.

Also please try printing from Elements Organizer once.

Try resetting the PSE preferences by

1. Close Elements.

2. Launch the Photoshop Elements Welcome Screen and hold down ctrl + alt + shift as you click Edit.

3. Continue to hold the keys until you see a message box asking if you want to delete Photoshop Elements settings file; click Yes. Elements will open with default preferences.