Lightroom Classic 9.0: Get "Not Compatible" message on Windows 10 Enterprise 64-bit "winver" 1709.

  • 1
  • Problem
  • Updated 8 months ago
  • Solved
  • (Edited)
Get "Not Compatible" message for Lightroom Classic 9.0 on Windows 10 Enterprise 64-bit (10.0.16299 Build 16299). When I type "winver", I get version 1709. I have Adobe CC subscription. Please help. Thank you.
Photo of Vipul Kapadia

Vipul Kapadia

  • 3 Posts
  • 2 Reply Likes

Posted 8 months ago

  • 1
Photo of Tom Mickow

Tom Mickow

  • 514 Posts
  • 210 Reply Likes
That's correct.  For Lr Classic 9, you need Win10 version 1809 or later.
You'll need to upgrade your Windows version before installing Lr 9.
(Edited)
Photo of Vipul Kapadia

Vipul Kapadia

  • 3 Posts
  • 2 Reply Likes
Ah! Thank you for letting me know. Since our installation is managed at the corporate level, I guess I just have to use the older version on Lr Classic :-( I wish Adobe provided a little lenient backward compatibility.
Photo of Edmund Gall

Edmund Gall

  • 156 Posts
  • 55 Reply Likes
It is being lenient, but if the technology it needs to work isn't available in an old operating system (OS) version, then Adobe must implement a cut-off point. If you are using an old OS that won't support the features of the newest LR version, then you'd have to use an older LR version that supports your OS choice. I don't think you have to go too far back - LR v 8.x supports Win 10 1709. So, you're not missing out on a huge amount if you don't use LR 9...
Photo of Vipul Kapadia

Vipul Kapadia

  • 3 Posts
  • 2 Reply Likes
Well, good news! We were just upgraded to the latest required version and now I am able to go to the newer version! Thank you, everyone!