Photoshop: Generator offsets and crops images randomly when resizing to a pixel dimension.

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
  • (Edited)
I have a number of layer groups that are masked to the edge of the artboard. When I use generator to export them without resizing them, the exported PNGs align perfectly. If I then manually resize the separate PNGs they remained aligned.

When I add 1000x1000 in front of the image title in the layer group to resize them, they will sometimes align but most often be offset randomly by between 10 and 50 pixels or so.

Occasionally the output PNGs will be cropped to 1000x1000 instead of being resized, though this behavior happens more rarely.

Original photoshop:

resized images composited together: 



Can this be fixed?
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
  • Frustrate

Posted 3 years ago

  • 1
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Hey Mark, there might be a workaround using a configuration file, but if I can repro what you're running into, we can work on possible better solution.  Sent you a message yesterday (check junk/spam if you didn't see it).  
Config file info: https://github.com/adobe-photoshop/generator-core/wiki/Generator-Configuration-File-Format
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Thanks Chad, I've replied to your email.
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Hi Chad, any luck with the files I sent you?
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Yes, thank you.  I can reproduce what you're running into.  Trying to isolate the problem...
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Great, thanks Chad.
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Hi Chad, any luck? This happens quite a lot and hampers our workflow.
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Official Response
Hey Mark, I have logged the bug and a developer is looking at it.  As soon as the developer can identify the problem in the code, we might be able to figure out a workaround, but for now, unfortunately, there isn't a workaround other than manually fixing the offset.  :(  Sorry, I know this is a pain.  I'll continue to follow up and poke the dev. 
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Thanks for the update Chad. 
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Hi Chad, just checking in to see if there's any update on this issue? 
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Hey Mark, Sorry, no update.  It's still on the developer's list of priorities but lower on the it.
Photo of mark murray

mark murray

  • 8 Posts
  • 0 Reply Likes
Hi Chad, any update on the fix?
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Hey Mark, yeah sorry, still no update.