Generate Assets Output incorrect - Fails to include clipping layers and adjustments

  • 1
  • Problem
  • Updated 2 years ago
I've originally posted this issue to the GitHub and they said it was fixed in the latest Photoshop update, but it has not fixed the issue on my end, and no one is replying over there anymore: https://github.com/adobe-photoshop/generator-assets/issues/415



Here is the low-res PSD example file for recreating the issue where the output does not match what you see in Photoshop:

angel_test2psd.zip

The problem: In general "generate assets" works great and as expected, but I use adjustment layers and image layers as clipping masks on parent groups of child and grandchild layers I want to output. Unfortunately the output seems to ignore all the grandparented clipping layers, but does respect masks if I use "include-ancestor-masks":true.

The latest CC update has not resolved this issue. I've worked around it, but it's a huge pain in the butt and time-waste. If you can find something I might be doing wrong or otherwise figure out how to get it to output correctly, please let me know.

Thanks


SaveSave
Photo of Joe Russ

Joe Russ

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 157 Reply Likes
Which version do you exactly have?
It works good for me: http://sklad.bereza.cz/00-jarda/00_screenshot/2016-09-02_213105.jpg
I changed top most color balance to purple and bitmaps deep inside groups are purple too.
Photo of Joe Russ

Joe Russ

  • 2 Posts
  • 0 Reply Likes
Hmm, glad it works on your end, maybe it's mac-version specific? I'm running OS X 10.11.6 and Photoshop 2015.5.1, which is the latest version as far as I can tell.

I just tried using the "export as" and I still get the wrong result:
 
(Edited)
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 763 Posts
  • 157 Reply Likes
Yes I should have exactly same version. I am on Windows.
But I don't see reason why there should be OS differences.