Frustrating Failure Trying to Use Photoshop Express Online From a PC

  • 1
  • Problem
  • Updated 1 year ago
Somebody need to alert a moderator or anybody at Adobe that can fix this stupid issue with Photoshop Express online while using a PC.  Win7 Ultimate (fully updated) and Google Chrome (latest version).

I have (eventually) done a post in the Photoshop Express forum - 'Where are Edited Photos Saved When Using Online Photoshop Express Editor?'.  That post explains the foolishness I encountered.

I was about ready to declare Express as a worthless piece of trash when I FINALLY stumbled upon the answer (on my own).  I had done a chat session about the issue - went threw 3 reps and the last one told me that there was no chat support for the PH Express online function.

This issue absolutely needs some attention.

Maybe this post will get it started.
Photo of Fred English

Fred English

  • 1 Post
  • 0 Reply Likes
  • irritated as Crap!

Posted 1 year ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2611 Posts
  • 333 Reply Likes
For those who want to try, here is how to get to the browser-based app:
http://www.photoshop.com/tools 
(click Start the Editor not TRY IT FREE)

The very first time I tried this, I had your experience, where clicking Done just canceled out of the editor without asking to Save.  Then I went back in and tried the X and it did ask to Save.  Now it's asking me to Save either way so seems to be working.

On the Android phone version of the PSEx app, there is no Done button, only a back-arrow to exit and that asks to Save.

I tried this in Chrome and it's just asking me to install the flash player, which is built into Chrome, so I suspect PSEx is not being updated, anymore--the page has a copyright of 2013, but the page is left there as marketing for Photoshop CC.

In short, I did have your experience, then tried it, again, and it was ok, so the page is capable of working, and isn't designed to work poorly, but obviously sometimes things don't work.

(Edited)