Photoshop: Certain brushes to have delayed initiation

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
  • (Edited)
I'm running the latest update for photoshop (CC), and I started noticing this tiny initiation lag on certain brushes that's mainly noticeable when I'm trying to do a series of small strokes. I'm not having lag issues as far as I can tell, it just seems the brush will not initiate on the canvas until after I drag it a certain distance away from it's starting point. The strangest part about it is the inconsistency of the problem. It seems to only be a problem with imported brushes and only with certain ones. And if I disable smoothing on the brush, it might fix it or it might not, and if it does, then it only fixes it for a few minutes. The reason I know it's not just input lag is that I can press firmly on the canvas and draw tiny circles with nothing showing up on the canvas until I either lift the pen up or I drag it further from the starting point. I also tested it with a mouse to make sure it wasn't just my tablet and it does the same exact thing, except for when I disable smoothing, then it is fixed for the mouse but not for my pen. Completely lost as to how to deal with this.
Photo of Losha Magee

Losha Magee

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 months ago

  • 1
Photo of Benjamin Golinvaux

Benjamin Golinvaux

  • 19 Posts
  • 9 Reply Likes
I noticed that too, but it was with the current version as of two years ago. VERY frustrating. I noticed that it only seemed to happen with natural media brushes, and not with the simple bitmapped brushes.

Have you tried turning GPU acceleration off and perhaps changing the settings (basic, advanced....)? That might help.
Photo of Losha Magee

Losha Magee

  • 4 Posts
  • 0 Reply Likes
I've tried turning off GPU acceleration as well as changing the drawing mode to advanced, but this issue does not seem to be connected to those settings. However, I just figured out it seems largely attributed to the "Dual Brush" setting under the individual brush settings. The brushes that don't use that setting don't have this problem. Though that doesn't explain how disabling smoothing on the problematic brushes will sometimes fix the issue for a short time. It's sort of killing photoshop for me right now. Might have to revert to an older version if you're right about it only being a problem for newer versions.
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 402 Reply Likes
Maybe your brush is set to the new smoothing option. Make sure that 'Smoothing' is set to zero.

(Edited)
Photo of Losha Magee

Losha Magee

  • 4 Posts
  • 0 Reply Likes
The new smoothing option (the one that you're pointing to) doesn't seem to have any correlation to the problem I'm experiencing. The smoothing checkbox under the brush setting will sometimes have an inconsistent effect with this issue, but the "Dual Brush" setting under the brush settings has the most direct influence over this problem, as I mentioned in my other comment. 
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1047 Posts
  • 402 Reply Likes
Are you sure that the drivers for your tablet are up to date?
Photo of Losha Magee

Losha Magee

  • 4 Posts
  • 0 Reply Likes
Yep, at least now they are, heh. I just updated them but it didn't change anything. I don't think it's a tablet problem considering the brushes do the same thing when I'm just using a mouse.
Photo of David Tristram

David Tristram, Employee

  • 118 Posts
  • 55 Reply Likes
Hi, did you say whether this was Mac or Windows?