Photoshop: Font issue in Export As dialog interface text is garbled

  • 3
  • Problem
  • Updated 11 months ago
  • (Edited)
I've updated to the latest OS on my MacBook Pro. When I try to use the "Export As" menu to save as a PNG or other web file, the header fonts like File Settings & Image size are working properly, but the fonts for everything else are missing and it's just a garble of characters.

I am unable to use this function because I can't read the specification options to save the file correctly.
Photo of Studio B Creative .

Studio B Creative .

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Could you post a screen shot of what you're seeing? That may help us.
Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
It sounds like you're saying that the font within the Photoshop application itself is corrupt.  Is that true?  Are you still seeing this issue?

Thanks,
David
Photo of Jason Hunt

Jason Hunt

  • 1 Post
  • 0 Reply Likes
I'm also having this – how can I fix this?
See screenshot attached.
Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
Hi Jason,

Have you deleted one or more fonts lately? Have you had problems with your fonts lately? I would guess that one or more of your system fonts have been removed. What SPECIFIC OS version are you running? If you click Help > System Info, then the second line displayed has the information I need. Similarly, which specific version of Photoshop are you running? That would be the same place, first line.

Thanks,

David
(Edited)
Photo of Derek Oyen

Derek Oyen

  • 1 Post
  • 0 Reply Likes
I was running into the exact same problem. Other windows were working fine (legacy Save for Web), but the Export As... menu was garbled. I'm running Photoshop CC 20151114.r.301 X64 on Mac OS 10.12.1.

I suspected a font conflict was causing the issue, so i disabled any non-system versions of the Helvetica Neue font family that I had running on my machine (we use Universal Type Client for font management at our agency). Shutting off the font appears to have fixed the problem.
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 283 Reply Likes

Hello!

Another user has the problem: https://forums.adobe.com/thread/2376562

Photo of David

David, Official Rep

  • 2716 Posts
  • 373 Reply Likes
This issue has also appeared in another thread: https://console.getsatisfaction.com/photoshop_family/conversations/export-as

But the quick answer is these are the fonts used for drawing the UI: San Francisco, Helvetica Neue, Lucida Grande, Segoe UI, and/or AdobeClean.  It sounds like there is an issue with Helvetica Neue and I believe that Apple had problems with it a few versions ago.  I would replace my Helvetica Neue with a known-good version and you should be fine.

Thanks,
David