Fixing "unkown lens" without re-importing

  • 1
  • Question
  • Updated 4 years ago
Merged

This conversation has been merged. Please reference the main conversation: Lightroom CC 2015: Lens metadata field missing on import

As a Nikon and Canon user, I've found a lot of images from the Nikons with "unknown lens". Is there a way to fix this, without actually re-importing the images? I do use the lens meta data a lot and it's very cumbersome to not being able to filter on a specific lens.
Photo of Jaak Thomas Arendi

Jaak Thomas Arendi

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5710 Posts
  • 2286 Reply Likes
Yes, either once you've rolled back to 6.4, or the next update (e.g. 6.5.1) has come out, you'll be able to select the affected photos, go to Metadata menu > Save Metadata to Files and then Metadata menu > Read Metadata from Files.
Photo of Jaak Thomas Arendi

Jaak Thomas Arendi

  • 5 Posts
  • 0 Reply Likes
Thanks for the prompt reply Victoria! :) Hopefully the next version will appear soon. It also seems that the problems with Nikon cameras are more common than with others. :/
Photo of lhiapgpeonk

lhiapgpeonk

  • 52 Posts
  • 5 Reply Likes
It has been stated in the Prolem thread to this - erm - problem, that you can save all metadata to the file(s) and then re-import the metadata from the file. That should work.

This conversation is no longer open for comments or replies.