Lightroom Classic: Filter doesn't stay selected while exporting

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
In the Library module, if I am exporting a portion of the images in a folder then select to filter via flag status while the export is taking place the filter does not stay selected, but instead resets to Filters Off. This makes it difficult to continually edit a different selection of images while an export is taking place. 

I did find a workaround though. If you quickly select all images directly after selecting the filter status to flagged, and before it resets to Filters Off, then you can scroll through only the flagged images even though the filter status has been automatically changed to Filters Off. 

Specs: iMac, macOS High Sierra Version 10.13.13, Lightroom Classic CC 7.3 Release
Photo of Travis C. Moore

Travis C. Moore

  • 3 Posts
  • 0 Reply Likes
  • annoyed

Posted 3 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1109 Posts
  • 446 Reply Likes
Are you adding the exported images to the catalog? If so, this is by design. Images that are added to the catalog won't have a flag, and so they would not show if the filter for flags was still active. Because that would be confusing (people might think the images aren't added at all) the filter is cleared.
Photo of Travis C. Moore

Travis C. Moore

  • 3 Posts
  • 0 Reply Likes
Yes, I am adding them back to the catalog in a subfolder. That's interesting. I can imagine the potential for people to not realize where the images are going... but then again, why allow the filter bar to be utilized at all during an export with adding the images back to the catalog? Wouldn't it make more sense to grey out the filter bars? 
(Edited)
Photo of John R. Ellis

John R. Ellis, Champion

  • 3487 Posts
  • 888 Reply Likes
Lock the filters by doing FIle > Library Filters > Lock Filters (or click the lock icon on the right of the filter bar). Then they won't reset when you export back to the catalog.
Photo of Travis C. Moore

Travis C. Moore

  • 3 Posts
  • 0 Reply Likes
Thank you!