Filename error when importing [Canon 5D mk III - LR 4.1 RC2]

  • 1
  • Problem
  • Updated 6 years ago
I have my Canon 5D mk III set to name each file as 5D00xxxx
On my first import, I deselected 'rename on import'
However, the files show up as _D00xxxx
The only files that were imported correctly were the movie files (neither JPG nor CR2 showed the 5 at the start of the name)
Photo of Eyal Oren

Eyal Oren

  • 14 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 334 Reply Likes
Did you recently change from sRGB to Adobe RGB for your JPEG/Raw Thumbnail rendering?

Typically an underscore means that you have set to Adobe RGB in your camera.
Photo of Eyal Oren

Eyal Oren

  • 14 Posts
  • 0 Reply Likes
It's a brand new camera - this was my first upload. But yet, I do have it set for aRGB color space. Is there anyway to fix this and keep the color space?
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
Filenames prepended with _ are a semi-standard among many manufacturers to denote a raw image captured with a preview using a specific camera RGB setting. An underscore elsewhere means sRGB I think.

When you set the name format in the camera, it will prepend or insert an underscore when it actually writes out the file, depending on the colour space of the image.

Are you shooting jpeg+raw?
Photo of Eyal Oren

Eyal Oren

  • 14 Posts
  • 0 Reply Likes
I was shooting jpg+raw and just switched to raw only but the filename is still showing up that way.

Shooting in sRGB solved the problem. Thanks. Now to figure out if it matters what color space I choose if I shoot raw...
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 334 Reply Likes
It doesn't matter what the color space is set to. Raw ignores it except for the embedded JPEG preview.
Photo of Eyal Oren

Eyal Oren

  • 14 Posts
  • 0 Reply Likes
Thanks. Always thought so but never saw it written down anywhere.

Was giving the JPGs a chance to see if was worth shooting those. Now that I'm done testing that, have set camera to sRGB for RAW only writing.

Appreciate the help.