File association for jpg files not working with new Photoshop on Windows

  • 6
  • Problem
  • Updated 1 year ago
  • (Edited)
Yesterday I upgraded to the 2015 release of CC and am now bothered with a problem of lack of file association in Windows with jpg files in relation to Photoshop CC 2015. I have used the regedit function to check the entry in the HKEY_CURRENT_USER, but the entry is all right. Photoshop simply does not show as an option in the "Open with" menu in Windows File Explorer.

Greetings Henrik Møller
Rudersdal Kommune
Denmark
hhmo@rudersdal.dk
Photo of Henrik Møller

Henrik Møller

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 6
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes
I'm having exactly the same issue. I'd really appreciate a solution to this as using Windows Photo Viewer is not going to cut it!!
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes
Think I've found a workaround...

I changed the the name of the application in Programme Files from photoshop.exe to photoshopCC2015.exe and it then appears in the 'open with' menu if you browse. However I'm not sure how this will affect other applications such as Lightroom etc...
Photo of Henrik Møller

Henrik Møller

  • 2 Posts
  • 0 Reply Likes
This has been most helpful, thank you so much - working for me too :)
Photo of James Kratzer

James Kratzer

  • 3 Posts
  • 0 Reply Likes
Okay, this will fix it. Go into the Windows registry under:

HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command

Change the default value to:

"C:\Program Files\Adobe\Adobe Photoshop CC 2015\Photoshop.exe" "%1"

Now when you right-click on a jpg file and select "Open With" you will have the option to use Photoshop CC 2015.
Photo of James Kratzer

James Kratzer

  • 3 Posts
  • 0 Reply Likes
This worked perfectly at first, but after a reboot it's not working again. :-(
Photo of James Kratzer

James Kratzer

  • 3 Posts
  • 0 Reply Likes
Got it working again, and the solution was even easier: I deleted the HKEY_CLASSES_ROOT\Applications\Photoshop.exe key entirely. Then I right-clicked on a jpg file and selected "Open With" and I browsed to the CC 2015 version of the Photoshop.exe file and that fixed it. Still working after reboot :-)
Photo of Rafael Echavarria

Rafael Echavarria

  • 8 Posts
  • 1 Reply Like
Nice!!!! Been looking for a solution forever, this worked!!!!!! Thanks!!!!!!!!!!! However, Adobe is not helping at all. I guess we should just switch if they continue like that.
Photo of Tim

Tim

  • 3 Posts
  • 0 Reply Likes
Just spoken to Adobe tech support who advised me that my method of changing the name of the application in the programmes folder, as outlined above in my previous post, is the correct way to deal with this issue. However, in addition, you will need to update the file association in Brigde as well by clicking Edit, Preferences, selecting JPG and browsing for the newly renamed .exe file.
Photo of Frank Nicholson

Frank Nicholson

  • 1 Post
  • 0 Reply Likes
Thank you Tim! I was having the same issue and your solution worked. However, I would like to add that you will now need to re-associate all the related file extensions too since you renamed the root .exe program. So, you can just go through and right click you psd's, tiff's and RAW files and associate them to PSCC2015.
Photo of Terri B

Terri B

  • 1 Post
  • 1 Reply Like
This is happening also with Photoshop CC 2017. Deleting the registry key as described in the comment I've quoted below appears to be the easiest and most effective fix for this problem  Just change the file association to Photoshop CC 2017 instead of 2015 (formatting for emphasis is mine).

-------------------

James Kratzer 

Got it working again, and the solution was even easier: I deleted the HKEY_CLASSES_ROOT\Applications\Photoshop.exe key entirely. Then I right-clicked on a jpg file and selected "Open With" and I browsed to the CC 2015 version of the Photoshop.exe file and that fixed it. Still working after reboot :-)