Photoshop 2019: Feedback/Bugs (lagging, rotate, deleted pixels, brush panel, anchor point issues)

  • 2
  • Problem
  • Updated 4 months ago
  • (Edited)
I was directed by Adobe customer support to post my feedback and bugs here. I have a list. Most of this is just feedback, but if there’s a fix for #3 please let me know!

I’m a Mac user on a 1.5 year old iMac with up to date Mac software (10.14) using the newest Photoshop 2019 update. Here are my issues having switched to the newest Photoshop.

1) When drawing and erasing with the default brushes, if I sketch using short quick strokes I get a bug sometimes where I get a little perfectly straight line, like it just connects point A to B rather than brushing along my path.

2) Laggy brushes/erasers produce the “loading” cursor while using them. If I am painting/erasing a long stroke (let’s say if I create a stroke and am drawing slowly for longer than a second), eventually the brush cursor will turn into the “loading” cursor, so I can’t actually see the edges of the brush.

3) If I select part of my layer and move it so it’s half on/half off the canvas, it deletes the part that’s off the canvas. If I move the whole layer half on/half off, I am still able to move it back onto the canvas and it retains the part that was outside the canvas edge. This only happens when I move PART of the layer out of frame then back in. How do I fix this? Bug or setting?

4) Brush Panel: To normally switch brushes while I work, I right click to bring up my brush panel. If I’m using a brush that’s somewhat large in size, when I mouse over to the panel to switch it, the panel disappears before I can select a new brush. It’s maddening. I have to downsize my brush in order to select a new brush via the brush panel, otherwise it keeps disappearing.

5) Rotating during Transform: I now have to hold my cursor very close to the transform box in order to rotate the selection. Previously, I could have it anywhere on the canvas and it would rotate. Seems incredibly pointless, wondering what the reasoning is behind this.

6) Anchor point during Transform/Rotate: It is not there automatically anymore, but is something I had to turn on in Settings. Why?

This software is not cheap, especially when you look at the yearly cost, and these glitches/changes really do slow down my workflow. I really hope they will be fixed. I’m not against changes, and I understand some changes are necessary when there is a purpose (like to be honest I’m OK with the new transform changes generally speaking, other than re-learning shortcuts I’ve spent 10+ years doing every day). But bugs and change for change’s sake is very frustrating.
Photo of S B

S B

  • 3 Posts
  • 2 Reply Likes

Posted 4 months ago

  • 2
Photo of Rich

Rich

  • 31 Posts
  • 12 Reply Likes
Other than posting here, did support offer any remedies for your bug issues? If not, I would find that more frustrating than the bugs themselves.
Hopefully you will have more success at a solution than have.

:)
Photo of S B

S B

  • 3 Posts
  • 2 Reply Likes
I didn't phrase the question as "can you help me with x, y, and z" but more so "where can I send this feedback that devs will actually read?"
So no, they didn't help me with any of these.

I'm not sure if the devs actually read these forums or not, but that's why I posted here. My Photoshop is definitely workable, I'm not having the same issues some people are that makes it completely unworkable. But yeah the bugs are annoying, and from someone that uses Photoshop professionally (and for fun) 10+ hours on the daily (and for nearly 10 years) these small quality-of-life things (including the feedback issues, not just the bugs) should be taken seriously by devs.
(Edited)
Photo of Kit Kerner

Kit Kerner

  • 35 Posts
  • 16 Reply Likes
I have been a user of Photoshop for years now too in Windows. I have been experiencing similar issues, like the brushes. My copy and paste works half the time, I'll copy something and it will paste what I copied before. Tech support has suggested a few things, I followed their advice, closed the program and even re-booted. Nothing has worked. I can't work and I think something is wrong. I'm not giving up, but I'm frustrated. You are not alone. Good luck.  

Photo of Rich

Rich

  • 31 Posts
  • 12 Reply Likes
We seem to be “ brothers” in frustration!!
Photo of Kit Kerner

Kit Kerner

  • 35 Posts
  • 16 Reply Likes
Here is what happened with me: I called Adobe Headquarters in  San Jose, CA. They transferred me to India to a Tech that transferred me to a second Tech. I gave them control of my computer and after several minutes he/we decided to reinstall a previous version, because they could not 'fix' my several issues. So, all my presets are gone (of course) and I have to recreate brushes I spent time on (big deal, I needed to thin them out). The good news is PS is working again. I'm not going to upgrade again until I know it is working. 
Photo of Rich

Rich

  • 31 Posts
  • 12 Reply Likes
I went through the same routine. But to be honest the techs I dealt with did attempt to resolve the issue. An older version still functions well,however why am I paying for something I can't use? So much for upgrades.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15327 Posts
  • 2222 Reply Likes
#1 - Are you using a Wacom tablet? I'd need more details and possibly a video for our painting expert to try and repro. Note: He's out until the New Year.
#2 - Known issue running on Mojave that we're working with Apple on.. See workaround here: https://feedback.photoshop.com/photoshop_family/topics/photoshop-cc-2019-healing-brush-clone-stamp-t... Hiding rulers also helps. add a Me Too/Vote to be informed when there's an update.
#3 - Are you moving a floating selection? As long as I keep it selected, it move back on the canvas. If I drop it/deselect it, then the pixels outside the image window are deleted. This is the way floating selections have worked since Photoshop 1.0. Instead, jump your selection to a new layer (cmd J) then reposition the new layer rather than using a floating selection
#4 - I'll run that by our painting expert as well.
#5 - Known issue. We're working on: https://feedback.photoshop.com/photoshop_family/topics/photoshop-transform-rotate-handle-interaction... add a Me Too/Vote to be informed when there's an update.
#6 - See Usability improvements - customers were accidentally dragging the anchor point when the wanted to move the layer. As you noted, you can click it on and forget it if you prefer it on all the time.
(Edited)
Photo of S B

S B

  • 3 Posts
  • 2 Reply Likes
Hey, I appreciate the response!!
I'll try and grab a video of #1 and #4 when I have some time though may not be til after the holidays. Yes, I'm using a Wacom Cintiq 13 (from around 2015).
Thanks again, it's nice to hear directly from you guys.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15327 Posts
  • 2222 Reply Likes
Cool. After the holidays is perfect. No rush.
Photo of Kit Kerner

Kit Kerner

  • 35 Posts
  • 16 Reply Likes
Number 3, what Mr. Tranberry wrote. If the selection of the layer, or part of the layer, is deselected then that part will not come back in when moved back. The section needs to remain 'selected'. Most of the time when moving the whole layer, I don't select it, just move it. Good Luck!