Lightroom CC 2015: Faulty Script in Web Module

  • 1
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
Faulty Script in Web Module of Lightroom CC 2015.1

There seems to be an error in one of the Scripts ( jquery.min.js) which is used by Lr 2015.1 to build Web Galleries.

If a user types the URL of their web site into the “Gallery Author URL” box; and a visitor to their Site then clicks on the Link, a 404 “Not Found” error page is triggered.

You can see an example of this if you go to this Page:
http://shelbourne-america.net/Tigers-...
and then click on my name:

Instead of transmitting “http://shelbourne-america.net”
the script instead triggers this triple-field URL:
http://shelbourne-america.net/Tigers-...
which leads only to a 404 Error page.

I find the Lightroom CC 2015 Galleries to be very disappointing in both their design and their functionality.

Adobe needs to provide a far greater range of Customisable Settings for text layout and sizing;
for spacing between thumbnails;
for positioning and formatting of the Main Title and also Caption boxes.

Most egregious of all?: There is no way to insert an eMail Contact Link into a Gallery page?!!

What were the designers of these Gallery templates thinking?!!

Bridge handles Gallery-building so much better than does Lr — even though Adobe has still not fixed its ability to Preview directly in a Browser from Bridge.
Photo of Ann Shelbourne

Ann Shelbourne

  • 149 Posts
  • 109 Reply Likes

Posted 3 years ago

  • 1
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 105 Reply Likes
Official Response
There is a bug logged on this. In the meantime, to work around this, just include "http://" before the URL you enter. That makes the link work properly for me. (Or if you want it to be a mail link, enter "mailto:" before your email address).